treewide: cleanup kernel symbol references
[openwrt/staging/jow.git] / package / kernel / linux / modules / fs.mk
index d7f36ba4e09bc693c5b0ff0119b03ab41ec61a2c..77d8d6c98bc8bb606a67f834fe57624be4610a26 100644 (file)
@@ -87,31 +87,29 @@ define KernelPackage/fs-cifs
   SUBMENU:=$(FS_MENU)
   TITLE:=CIFS support
   KCONFIG:= \
-       CONFIG_SMBFS_COMMON@ge5.15 \
+       CONFIG_SMBFS_COMMON \
        CONFIG_CIFS \
        CONFIG_CIFS_DFS_UPCALL=n \
        CONFIG_CIFS_UPCALL=n
   FILES:= \
-       $(LINUX_DIR)/fs/smbfs_common/cifs_arc4.ko@ge5.15 \
-       $(LINUX_DIR)/fs/smbfs_common/cifs_md4.ko@ge5.15 \
+       $(LINUX_DIR)/fs/smbfs_common/cifs_arc4.ko \
+       $(LINUX_DIR)/fs/smbfs_common/cifs_md4.ko \
        $(LINUX_DIR)/fs/cifs/cifs.ko
   AUTOLOAD:=$(call AutoLoad,30,cifs)
   $(call AddDepends/nls)
   DEPENDS+= \
-    +LINUX_5_10:kmod-crypto-md4\
     +kmod-crypto-md5 \
     +kmod-crypto-sha256 \
     +kmod-crypto-sha512 \
     +kmod-crypto-cmac \
     +kmod-crypto-hmac \
-    +LINUX_5_10:kmod-crypto-arc4 \
     +kmod-crypto-aead \
     +kmod-crypto-ccm \
     +kmod-crypto-ecb \
     +kmod-crypto-des \
-    +(LINUX_5_15):kmod-asn1-decoder \
-    +(LINUX_5_15):kmod-oid-registry \
-    +(LINUX_5_15):kmod-dnsresolver
+    +kmod-asn1-decoder \
+    +kmod-oid-registry \
+    +kmod-dnsresolver
 endef
 
 define KernelPackage/fs-cifs/description
@@ -367,7 +365,6 @@ $(eval $(call KernelPackage,fs-msdos))
 define KernelPackage/fs-netfs
   SUBMENU:=$(FS_MENU)
   TITLE:=Network Filesystems support
-  DEPENDS:=@LINUX_5_15
   KCONFIG:= CONFIG_NETFS_SUPPORT
   FILES:=$(LINUX_DIR)/fs/netfs/netfs.ko
   AUTOLOAD:=$(call AutoLoad,28,netfs)
@@ -510,7 +507,7 @@ $(eval $(call KernelPackage,fs-nfsd))
 
 define KernelPackage/fs-ntfs
   SUBMENU:=$(FS_MENU)
-  TITLE:=NTFS filesystem support
+  TITLE:=NTFS filesystem read-only (old driver) support
   KCONFIG:=CONFIG_NTFS_FS
   FILES:=$(LINUX_DIR)/fs/ntfs/ntfs.ko
   AUTOLOAD:=$(call AutoLoad,30,ntfs)
@@ -518,7 +515,8 @@ define KernelPackage/fs-ntfs
 endef
 
 define KernelPackage/fs-ntfs/description
- Kernel module for NTFS filesystem support
+ Kernel module for limited NTFS filesystem support. Support for writing
+ is extremely limited and disabled as a result.
 endef
 
 $(eval $(call KernelPackage,fs-ntfs))
@@ -526,16 +524,18 @@ $(eval $(call KernelPackage,fs-ntfs))
 
 define KernelPackage/fs-ntfs3
   SUBMENU:=$(FS_MENU)
-  TITLE:=Ntfs3 support
+  TITLE:=NTFS filesystem read & write (new driver) support
   KCONFIG:= CONFIG_NTFS3_FS CONFIG_NTFS3_FS_POSIX_ACL=y
   FILES:=$(LINUX_DIR)/fs/ntfs3/ntfs3.ko
   $(call AddDepends/nls)
-  DEPENDS+=@!LINUX_5_10
   AUTOLOAD:=$(call AutoLoad,80,ntfs3)
 endef
 
-define KernelPackage/fuse/description
- Kernel module for new NTFS3 filesystem support
+define KernelPackage/fs-ntfs3/description
+ Kernel module for fully functional NTFS filesystem support. It allows
+ reading as well as writing.
+
+ It supports NTFS versions up to 3.1.
 endef
 
 $(eval $(call KernelPackage,fs-ntfs3))