pwm support can't be compiled as a module
[openwrt/staging/blogic.git] / package / kernel / linux / modules / other.mk
index b1bb76a89256444106dc492cb345343acabe8140..eed258dc22b9a4b52c0f4d0aab2f5f7b3f3c8cc1 100644 (file)
@@ -495,20 +495,6 @@ endef
 $(eval $(call KernelPackage,booke-wdt))
 
 
-define KernelPackage/pwm
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=PWM generic API
-  KCONFIG:=CONFIG_GENERIC_PWM
-  FILES:=$(LINUX_DIR)/drivers/pwm/pwm.ko
-endef
-
-define KernelPackage/pwm/description
- Kernel module that implement a generic PWM API
-endef
-
-$(eval $(call KernelPackage,pwm))
-
-
 define KernelPackage/rtc-ds1307
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support