[netfilter] package u32 match and TEE target, patches by Maxim Uvarov
[openwrt/svn-archive/archive.git] / package / kernel / modules / 001-depends.mk
index 5cb34120813d85457ed2e8d245105efcc76738eb..602775c0157a5a0e0ac187005914fd84b17bc7c1 100644 (file)
@@ -12,7 +12,7 @@ define SetDepends/crc16
 endef
 
 define AddDepends/crc16
-  DEPENDS+= +!TARGET_xburst:kmod-crc16
+  DEPENDS+= +!TARGET_xburst:kmod-crc16 $(1)
 endef
 
 
@@ -21,7 +21,7 @@ define SetDepends/hid
 endef
 
 define AddDepends/hid
-  DEPENDS+= +!TARGET_x86:kmod-hid
+  DEPENDS+= +!TARGET_x86:kmod-hid $(1)
 
 endef
 
@@ -31,15 +31,14 @@ define SetDepends/input
 endef
 
 define AddDepends/input
-  DEPENDS+= +!TARGET_x86:kmod-input-core
+  DEPENDS+= +!TARGET_x86:kmod-input-core $(1)
 endef
 
 
 define SetDepends/rfkill
-  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86)
+  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini)
 endef
 
 define AddDepends/rfkill
-  DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill
-
+  DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill $(1)
 endef