package/kernel: set correct submenu entry for NLS packages
[openwrt/staging/yousong.git] / package / kernel / modules / other.mk
index 48bf1ab996cef783caa39aa638b6f0bf59f0fefe..fbaf7638da3391d28bc53593fb2fb168ee2075f3 100644 (file)
@@ -64,7 +64,8 @@ define KernelPackage/crc16
   TITLE:=CRC16 support
   KCONFIG:=CONFIG_CRC16
   FILES:=$(LINUX_DIR)/lib/crc16.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,20,crc16)
+  AUTOLOAD:=$(call AutoLoad,20,crc16,1)
+  $(call SetDepends/crc16)
 endef
 
 define KernelPackage/crc16/description
@@ -261,7 +262,7 @@ $(eval $(call KernelPackage,ssb))
 define KernelPackage/bluetooth
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Bluetooth support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core +!TARGET_x86:kmod-hid
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core
   KCONFIG:= \
        CONFIG_BLUEZ \
        CONFIG_BLUEZ_L2CAP \
@@ -280,6 +281,9 @@ define KernelPackage/bluetooth
        CONFIG_BT_HCIUSB \
        CONFIG_BT_HCIUART \
        CONFIG_BT_HIDP
+  $(call AddDepends/crc16)
+  $(call AddDepends/hid)
+  $(call AddDepends/rfkill)
 endef
 
 define KernelPackage/bluetooth/2.4
@@ -651,10 +655,11 @@ $(eval $(call KernelPackage,sc520-wdt))
 define KernelPackage/input-core
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Input device core
-  DEPENDS:=@LINUX_2_6 @!TARGET_x86
+  DEPENDS:=@LINUX_2_6
   KCONFIG:=CONFIG_INPUT
   FILES:=$(LINUX_DIR)/drivers/input/input-core.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,19,input-core)
+  $(call SetDepends/input)
 endef
 
 define KernelPackage/input-core/description
@@ -667,10 +672,10 @@ $(eval $(call KernelPackage,input-core))
 define KernelPackage/input-evdev
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Input event device
-  DEPENDS:=+!TARGET_x86:kmod-input-core
   KCONFIG:=CONFIG_INPUT_EVDEV
   FILES:=$(LINUX_DIR)/drivers/input/evdev.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,evdev)
+  $(call AddDepends/input)
 endef
 
 define KernelPackage/input-evdev/description
@@ -683,10 +688,12 @@ $(eval $(call KernelPackage,input-evdev))
 define KernelPackage/hid
   SUBMENU:=$(OTHER_MENU)
   TITLE:=HID Devices
-  DEPENDS:=+kmod-input-core +kmod-input-evdev @!TARGET_x86
+  DEPENDS:=+kmod-input-evdev
   KCONFIG:=CONFIG_HID
   FILES:=$(LINUX_DIR)/drivers/hid/hid.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,61,hid)
+  $(call SetDepends/hid)
+  $(call AddDepends/input)
 endef
 
 define KernelPackage/hid/description
@@ -699,10 +706,11 @@ $(eval $(call KernelPackage,hid))
 define KernelPackage/input-polldev
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Polled Input device support
-  DEPENDS:=+!TARGET_x86:kmod-input-core @LINUX_2_6
+  DEPENDS:=@LINUX_2_6
   KCONFIG:=CONFIG_INPUT_POLLDEV
   FILES:=$(LINUX_DIR)/drivers/input/input-polldev.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,20,input-polldev)
+  $(call AddDepends/input)
 endef
 
 define KernelPackage/input-polldev/description
@@ -715,10 +723,11 @@ $(eval $(call KernelPackage,input-polldev))
 define KernelPackage/input-gpio-keys
   SUBMENU:=$(OTHER_MENU)
   TITLE:=GPIO key support
-  DEPENDS:= @GPIO_SUPPORT +!TARGET_x86:kmod-input-core
+  DEPENDS:= @GPIO_SUPPORT
   KCONFIG:=CONFIG_KEYBOARD_GPIO
   FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,gpio_keys)
+  $(call AddDepends/input)
 endef
 
 define KernelPackage/input-gpio-keys/description
@@ -749,10 +758,10 @@ $(eval $(call KernelPackage,input-gpio-buttons))
 define KernelPackage/input-joydev
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Joystick device support
-  DEPENDS:=+!TARGET_x86:kmod-input-core
   KCONFIG:=CONFIG_INPUT_JOYDEV
   FILES:=$(LINUX_DIR)/drivers/input/joydev.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,62,joydev)
+  $(call AddDepends/input)
 endef
 
 define KernelPackage/input-joydev/description
@@ -798,10 +807,10 @@ $(eval $(call KernelPackage,mmc-atmelmci,1))
 define KernelPackage/cs5535-gpio
   SUBMENU:=$(OTHER_MENU)
   TITLE:=AMD CS5535/CS5536 GPIO driver
-  DEPENDS:=@TARGET_x86||@TARGET_olpc
+  DEPENDS:=@TARGET_x86
   KCONFIG:=CONFIG_CS5535_GPIO
   FILES:=$(LINUX_DIR)/drivers/char/cs5535_gpio.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,90,cs5535_gpio)
+  AUTOLOAD:=$(call AutoLoad,50,cs5535_gpio)
 endef
 
 define KernelPackage/cs5535-gpio/description
@@ -851,7 +860,6 @@ $(eval $(call KernelPackage,textsearch))
 define KernelPackage/rfkill
   SUBMENU:=$(OTHER_MENU)
   TITLE:=RF switch subsystem support
-  DEPENDS:=@TARGET_x86||TARGET_olpc||TARGET_s3c24xx||TARGET_brcm47xx||TARGET_ar71xx
   KCONFIG:= \
     CONFIG_RFKILL \
     CONFIG_RFKILL_INPUT=y \
@@ -866,6 +874,7 @@ else
     $(LINUX_DIR)/net/rfkill/rfkill-input.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,20,rfkill rfkill-input)
 endif
+  $(call SetDepends/rfkill)
 endef
 
 define KernelPackage/rfkill/description
@@ -874,3 +883,34 @@ define KernelPackage/rfkill/description
 endef
 
 $(eval $(call KernelPackage,rfkill))
+
+define KernelPackage/geodewdt
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Geode/LX Watchdog timer
+  DEPENDS:=@TARGET_x86 @LINUX_2_6
+  KCONFIG:=CONFIG_GEODE_WDT
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/geodewdt.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,geodewdt)
+endef
+
+define KernelPackage/geodewdt/description
+  Kernel module for Geode watchdog timer.
+endef
+
+$(eval $(call KernelPackage,geodewdt))
+
+define KernelPackage/pc8736x-gpio
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=PC8736x GPIO support
+  DEPENDS:=@TARGET_x86
+  KCONFIG:=CONFIG_PC8736x_GPIO
+  FILES:=$(LINUX_DIR)/drivers/char/pc8736x_gpio.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,40,pc8736x_gpio)
+endef
+
+define KernelPackage/pc8736x-gpio/description
+ Kernel module for PC8736x GPIO
+endef
+
+$(eval $(call KernelPackage,pc8736x-gpio))
+