mark b44 as broken, it doesn't build anymore due to SSB changes apparently (closes...
[openwrt/svn-archive/archive.git] / package / kernel / modules / sound.mk
index 11d816b366d671ffc933ec1282fbc0aa9b28e14f..af637dfd2b31e99170274dee4d055e7cf939fb3b 100644 (file)
@@ -88,3 +88,19 @@ endef
 
 $(eval $(call KernelPackage,sound-i8x0))
 
+define KernelPackage/sound-cs5535audio
+  SUBMENU:=$(SOUND_MENU)
+  TITLE:=CS5535 PCI Controller
+  DEPENDS:=kmod-sound-core
+  KCONFIG:=CONFIG_SND_CS5535AUDIO
+  FILES:=$(LINUX_DIR)/sound/pci/cs5535audio/snd-cs5535audio.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/sound/ac97_bus.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/sound/pci/ac97/snd-ac97-codec.$(LINUX_KMOD_SUFFIX) 
+  AUTOLOAD:=$(call AutoLoad,35, ac97_bus snd-ac97-codec snd-cs5535audio)
+endef
+
+define KernelPackage/sound-cs5535audio/description
+ support for the integrated AC97 sound device on olpc
+endef
+
+$(eval $(call KernelPackage,sound-cs5535audio))