add missing kmod-hid module (thx, fish)
[openwrt/staging/wigyori.git] / package / kernel / modules / usb.mk
index bfe14f642dd810b8e5f81d0a121ac0e5eb8b7ec4..0f6b8c7860c88e64e42e3941fbaf33e7f11dd91a 100644 (file)
@@ -561,7 +561,7 @@ $(eval $(call KernelPackage,usb-net-cdc-ether))
 
 
 define KernelPackage/usb-hid
-  $(call usbdep,@LINUX_2_6 +kmod-input-core +kmod-input-evdev)
+  $(call usbdep,@LINUX_2_6 +kmod-input-core +kmod-input-evdev +kmod-hid)
   TITLE:=Support for USB Human Input Devices
   KCONFIG:=CONFIG_HID_SUPPORT=y CONFIG_USB_HID
   FILES:=$(LINUX_DIR)/drivers/$(USBHID_DIR)/usbhid.ko