Add preliminary support for the Routerboard 153 CF slot (#2550)
[openwrt/svn-archive/archive.git] / package / keynote / Makefile
index 47469b61c3490e0e1f58ef02bf3d973235964eba..1aea7cbc608fee085ef6230b591347f1215f494f 100644 (file)
@@ -7,11 +7,10 @@
 # $Id$
 
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=keynote
 PKG_VERSION:=2.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
@@ -24,39 +23,38 @@ define Package/keynote
   CATEGORY:=Network
   DEPENDS:=@LINUX_2_6 +libopenssl
   TITLE:=Simple and flexible trust-management system
-  DESCRIPTION:=\
-       KeyNote is a simple and flexible trust-management system designed to work \\\
-       well for a variety of large- and small- scale Internet-based applications.\\\
-       It provides a single, unified language for both local policies and \\\
-       credentials. 
   URL:=http://www1.cs.columbia.edu/~angelos/keynote.html
 endef
 
+define Package/keynote/description
+ KeyNote is a simple and flexible trust-management system designed to work 
+ well for a variety of large- and small- scale Internet-based applications.
+ It provides a single, unified language for both local policies and 
+ credentials.
+endef
+
 CONFIGURE_ARGS += \
        --enable-static \
        --enable-shared
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               LIBS="$(EXTRA_LDFLAGS) -L. -lkeynote -lm -lcrypto" \
-       )
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS)"
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/libkeynote.a $(STAGING_DIR)/usr/lib/
+       mkdir -p $(1)/usr/include/keynote
+       $(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(1)/usr/include/keynote/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libkeynote.a $(1)/usr/lib/
 endef
 
 define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/keynote \
-               $(STAGING_DIR)/usr/lib/libkeynote.a
+       rm -rf  $(1)/usr/include/keynote \
+               $(1)/usr/lib/libkeynote.a
 endef
 
 define Package/keynote/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/keynote $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/keynote $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,keynote))