wolfssl: enable openssl 1.0.1 compatibility
[openwrt/staging/chunkeey.git] / package / libs / cyassl / Makefile
index 038ef49ee3156a3b6db240743491c50e204b1e62..a2b3b5eef1ed8ea5d38aca51441fd456fe85147c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wolfssl
-PKG_VERSION:=3.6.0
+PKG_VERSION:=3.9.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
-PKG_SOURCE_URL:=http://www.wolfssl.com/
-PKG_MD5SUM:=fea119ce10c715d3f22514b5b387781e
+PKG_SOURCE_URL:=https://www.wolfssl.com/
+PKG_MD5SUM:=f3396726a9befd61443c2cce216e39ba
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
@@ -38,19 +38,19 @@ endef
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
-       --without-zlib \
        --enable-singlethreaded \
        --enable-opensslextra \
        --enable-sni \
+       --enable-stunnel \
        --enable-ecc \
        --disable-examples
 
-ifneq ($(CONFIG_TARGET_x86),)
-       CONFIGURE_ARGS += --enable-intelasm
-endif
-ifneq ($(CONFIG_TARGET_x86_64),)
-       CONFIGURE_ARGS += --enable-intelasm
-endif
+#ifneq ($(CONFIG_TARGET_x86),)
+#      CONFIGURE_ARGS += --enable-intelasm
+#endif
+#ifneq ($(CONFIG_TARGET_x86_64),)
+#      CONFIGURE_ARGS += --enable-intelasm
+#endif
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include