libnftnl: Activate link time optimization (LTO)
[openwrt/staging/rmilecki.git] / package / libs / libnftnl / Makefile
index 45e8a8a3d614a1c58145166f4188c265a8cc41a0..c56fb068ce941c1c7c777a1139eac243f13b1142 100644 (file)
@@ -8,15 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnftnl
-PKG_VERSION:=1.0.2+2014-10-02
-PKG_RELEASE:=1
+PKG_VERSION:=1.1.7
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=git://git.netfilter.org/libnftnl
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=4c34b74ffec41b58178998904c25ecf2471f2387
+PKG_SOURCE_URL:=https://netfilter.org/projects/$(PKG_NAME)/files
+PKG_HASH:=20dbc13f11004aea2c9e479cfb90359cb11fe3446c3140811c18e4ec1648ed8f
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
+PKG_LICENSE:=GPL-2.0+
 
 PKG_FIXUP:=autoreconf
 
@@ -24,12 +23,15 @@ PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+DISABLE_NLS:=
+
 define Package/libnftnl
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=+libmnl
   TITLE:=Low-level netlink library for the nf_tables subsystem
   URL:=http://www.netfilter.org/projects/libnftnl
+  ABI_VERSION:=12
 endef
 
 define Package/libnftnl/description
@@ -37,13 +39,12 @@ define Package/libnftnl/description
  programming interface (API) to the in-kernel nf_tables subsystem.
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -flto
+TARGET_LDFLAGS += -flto
 
 CONFIGURE_ARGS += \
        --enable-static \
-       --enable-shared \
-       --without-json-parsing \
-       --without-xml-parsing \
+       --enable-shared
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/libnftnl