libpcap: update to current upstream version 1.5.3
[openwrt/staging/wigyori.git] / package / libs / libpcap / Makefile
index f1d287225454a4bdf37b5f742f646f2d1f8e490b..347b180ba26b478230dbd4011d34e50336bf7bc7 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libpcap
-PKG_VERSION:=1.3.0
+PKG_VERSION:=1.5.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tcpdump.org/release/
-PKG_MD5SUM:=f78455a92622b7a3c05c58b6ad1cec7e
+PKG_MD5SUM:=7e7321fb3aff2f2bb05c8229f3795d4a
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
@@ -54,7 +54,6 @@ CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
        --disable-yydebug \
-       --enable-ipv6 \
        --with-build-cc="$(HOSTCC)" \
        --with-pcap=linux \
        --without-septel \
@@ -62,6 +61,11 @@ CONFIGURE_ARGS += \
        --without-libnl \
        --disable-can
 
+ifeq ($(CONFIG_IPV6),y)
+CONFIGURE_ARGS += \
+       --enable-ipv6
+endif
+
 MAKE_FLAGS += \
        CCOPT="$(TARGET_CFLAGS) -I$(BUILD_DIR)/linux/include"