treewide: clean up download hashes
[openwrt/staging/wigyori.git] / package / libs / libreadline / Makefile
index 320d2e2df60da18997a6a480e29e864f3081b0bf..3c1b048fe8fe0715d45e578806601debefa1387c 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=readline
-PKG_VERSION:=5.2
-PKG_RELEASE:=2
+PKG_VERSION:=7.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/readline
-PKG_MD5SUM:=e39331f32ad14009b9ff49cc10c5e751
+PKG_HASH:=750d437185286f40a369e1e4f4764eda932b9459b5ec9a731628393dd3d32334
 
-PKG_LICENSE:=GPLv2
+PKG_LICENSE:=GPL-3.0
 PKG_LICENSE_FILES:=COPYING
 
+PKG_BUILD_PARALLEL:=1
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libreadline
@@ -25,6 +29,7 @@ define Package/libreadline
   CATEGORY:=Libraries
   TITLE:=Command lines edition library
   URL:=http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
+  ABI_VERSION:=$(PKG_VERSION)
 endef
 
 define Package/libreadline/description
@@ -36,34 +41,32 @@ define Package/libreadline/description
        history expansion on previous commands.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --without-curses \
-       )
-endef
+# prevent "autoreconf" from removing "aclocal.m4"
+PKG_REMOVE_FILES:=
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --with-curses \
+
+CONFIGURE_VARS += \
+       bash_cv_wcwidth_broken=no \
+       bash_cv_func_sigsetjmp=yes \
 
 TARGET_CPPFLAGS:=-I. -I.. $(TARGET_CPPFLAGS)
 
 TARGET_CFLAGS += $(FPIC)
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/readline $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{a,so,so.5,so.5.2} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{a,so,so.7,so.7.0} $(1)/usr/lib/
 endef
 
 define Package/libreadline/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{so,so.5,so.5.2} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{so,so.7,so.7.0} $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libreadline))