treewide: replace nbd@openwrt.org with nbd@nbd.name
[openwrt/staging/noltari.git] / package / libs / libusb / Makefile
index 2796b051d53a742f37c815e718fe87ff6dc3b185..1b1edeef37f3c5684584736828ce7dbc6d758184 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2013 OpenWrt.org
+# Copyright (C) 2010-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libusb
-PKG_VERSION:=1.0.9
+PKG_VERSION:=1.0.20
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=7f5a02375ad960d4e33a6dae7d63cfcb
+PKG_MD5SUM:=1d4eb194eaaa2bcfbba28102768c7dbf
 
 PKG_INSTALL:=1
-PKG_BUILD_PARALLEL:=1
+PKG_BUILD_PARALLEL:=0
 PKG_LICENSE:=LGPL-2.1
 
-PKG_MAINTAINER := Felix Fietkau <nbd@openwrt.org>
+PKG_MAINTAINER := Felix Fietkau <nbd@nbd.name>
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -37,6 +37,9 @@ define Package/libusb-1.0/description
 endef
 
 TARGET_CFLAGS += $(FPIC)
+CONFIGURE_ARGS += \
+       --disable-udev \
+       --disable-log
 
 define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/