madwifi: add missing include file for the tools multicall binary
[openwrt/staging/florian.git] / package / madwifi / patches / 102-multicall_binary.patch
index cdbc0eb15b7a05384618434b89db11df60b5bf11..d3533ec68abcec5e0d27521799d99f7676e791d7 100644 (file)
-Index: madwifi-dfs-r3053/tools/80211debug.c
-===================================================================
---- madwifi-dfs-r3053.orig/tools/80211debug.c  2007-12-13 05:25:10.786240140 +0100
-+++ madwifi-dfs-r3053/tools/80211debug.c       2007-12-13 05:25:11.226265215 +0100
-@@ -49,6 +49,10 @@
+--- a/tools/80211debug.c
++++ b/tools/80211debug.c
+@@ -48,6 +48,7 @@
+ #include <ctype.h>
  #include <getopt.h>
  #include <err.h>
-+#ifdef DOMULTI
 +#include "do_multi.h"
-+#endif
-+
  #undef ARRAY_SIZE
  #define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
-@@ -184,9 +188,19 @@
- }
+@@ -185,7 +186,7 @@
  #endif /* __linux__ */
  
-+#ifdef DOMULTI
-+
-+int
-+a80211debug_init(int argc, char *argv[])
-+{
-+
-+#else
-+
  int
- main(int argc, char *argv[])
+-main(int argc, char *argv[])
++CMD(a80211debug)(int argc, char *argv[])
  {
-+
-+#endif
        const char *ifname = "ath0";
        const char *cp, *tp;
-       const char *sep;
-Index: madwifi-dfs-r3053/tools/80211stats.c
-===================================================================
---- madwifi-dfs-r3053.orig/tools/80211stats.c  2007-12-13 05:25:10.794240595 +0100
-+++ madwifi-dfs-r3053/tools/80211stats.c       2007-12-13 05:25:11.226265215 +0100
-@@ -60,6 +60,10 @@
+--- a/tools/80211stats.c
++++ b/tools/80211stats.c
+@@ -59,6 +59,7 @@
+ #include "net80211/ieee80211.h"
  #include "net80211/ieee80211_crypto.h"
  #include "net80211/ieee80211_ioctl.h"
-+#ifdef DOMULTI
 +#include "do_multi.h"
-+#endif
-+
  #ifndef SIOCG80211STATS
  #define       SIOCG80211STATS (SIOCDEVPRIVATE + 2)
- #endif
-@@ -239,9 +243,19 @@
- #undef STAT
+@@ -240,7 +241,7 @@
  }
  
-+#ifdef DOMULTI
-+
-+int
-+a80211stats_init(int argc, char *argv[])
-+{
-+
-+#else
-+
  int
- main(int argc, char *argv[])
+-main(int argc, char *argv[])
++CMD(a80211stats)(int argc, char *argv[])
  {
-+
-+#endif
        int c, len;
        struct ieee80211req_sta_info *si;
-       u_int8_t buf[24*1024], *cp;
-Index: madwifi-dfs-r3053/tools/athchans.c
-===================================================================
---- madwifi-dfs-r3053.orig/tools/athchans.c    2007-12-13 05:25:10.798240825 +0100
-+++ madwifi-dfs-r3053/tools/athchans.c 2007-12-13 05:25:11.238265900 +0100
-@@ -59,6 +59,10 @@
+--- a/tools/athchans.c
++++ b/tools/athchans.c
+@@ -58,6 +58,7 @@
+ #include "net80211/ieee80211.h"
  #include "net80211/ieee80211_crypto.h"
  #include "net80211/ieee80211_ioctl.h"
-+#ifdef DOMULTI
 +#include "do_multi.h"
-+#endif
-+
  static        int s = -1;
  static const char *progname;
-@@ -139,9 +143,20 @@
+@@ -140,8 +141,9 @@
  }
  
  #define       MAXCHAN ((int)(sizeof(struct ieee80211req_chanlist) * NBBY))
-+
-+#ifdef DOMULTI
-+
-+int
-+athchans_init(int argc, char *argv[])
-+{
-+
-+#else
 +
  int
- main(int argc, char *argv[])
+-main(int argc, char *argv[])
++CMD(athchans)(int argc, char *argv[])
  {
-+
-+#endif
        const char *ifname = "wifi0";
        struct ieee80211req_chanlist chanlist;
-       int c;
-Index: madwifi-dfs-r3053/tools/athctrl.c
-===================================================================
---- madwifi-dfs-r3053.orig/tools/athctrl.c     2007-12-13 05:25:10.806241280 +0100
-+++ madwifi-dfs-r3053/tools/athctrl.c  2007-12-13 05:25:11.242266126 +0100
-@@ -53,6 +53,10 @@
+--- a/tools/athctrl.c
++++ b/tools/athctrl.c
+@@ -52,6 +52,7 @@
+ #include <err.h>
  
  #include <net/if.h>
-+#ifdef DOMULTI
 +#include "do_multi.h"
-+#endif
-+
  static int
  setsysctrl(const char *dev, const char *control , u_long value)
- {
-@@ -87,9 +91,19 @@
-       exit(1);
+@@ -88,7 +89,7 @@
  }
  
-+#ifdef DOMULTI
-+
-+int
-+athctrl_init(int argc, char *argv[])
-+{
-+
-+#else
-+
  int
- main(int argc, char *argv[])
+-main(int argc, char *argv[])
++CMD(athctrl)(int argc, char *argv[])
  {
-+
-+#endif
        char device[IFNAMSIZ + 1];
        int distance = -1;
-       int c;
-Index: madwifi-dfs-r3053/tools/athdebug.c
-===================================================================
---- madwifi-dfs-r3053.orig/tools/athdebug.c    2007-12-13 05:25:10.814241735 +0100
-+++ madwifi-dfs-r3053/tools/athdebug.c 2007-12-13 05:25:11.242266126 +0100
-@@ -52,6 +52,10 @@
+--- a/tools/athdebug.c
++++ b/tools/athdebug.c
+@@ -51,6 +51,7 @@
+ #include <ctype.h>
  #include <getopt.h>
  #include <err.h>
-+#ifdef DOMULTI
 +#include "do_multi.h"
-+#endif
-+
  #undef ARRAY_SIZE
  #define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
-@@ -193,9 +197,20 @@
- }
+@@ -194,7 +195,7 @@
  #endif /* __linux__ */
  
-+#ifdef DOMULTI
-+
-+int
-+athdebug_init(int argc, char *argv[])
-+{
-+
-+#else
-+
  int
- main(int argc, char *argv[])
+-main(int argc, char *argv[])
++CMD(athdebug)(int argc, char *argv[])
  {
-+
-+#endif
-+
  #ifdef __linux__
        const char *ifname = "wifi0";
- #else
-Index: madwifi-dfs-r3053/tools/athkey.c
-===================================================================
---- madwifi-dfs-r3053.orig/tools/athkey.c      2007-12-13 05:25:10.818241964 +0100
-+++ madwifi-dfs-r3053/tools/athkey.c   2007-12-13 05:25:11.242266126 +0100
-@@ -59,6 +59,10 @@
+--- a/tools/athkey.c
++++ b/tools/athkey.c
+@@ -58,6 +58,7 @@
+ #include "net80211/ieee80211.h"
  #include "net80211/ieee80211_crypto.h"
  #include "net80211/ieee80211_ioctl.h"
-+#ifdef DOMULTI
 +#include "do_multi.h"
-+#endif
-+
  static int s = -1;
  static const char *progname;
-@@ -212,9 +216,19 @@
+@@ -213,8 +214,7 @@
        exit(-1);
  }
  
-+#ifdef DOMULTI
-+
-+int
-+athkey_init(int argc, char *argv[])
-+{
-+
-+#else
-+
- int
- main(int argc, char *argv[])
+-int
+-main(int argc, char *argv[])
++int CMD(athkey)(int argc, char *argv[])
  {
-+
-+#endif
        const char *ifname = "wifi0";
        struct ieee80211req_key setkey;
-       struct ieee80211req_del_key delkey;
-Index: madwifi-dfs-r3053/tools/athstats.c
-===================================================================
---- madwifi-dfs-r3053.orig/tools/athstats.c    2007-12-13 05:25:10.826242419 +0100
-+++ madwifi-dfs-r3053/tools/athstats.c 2007-12-13 05:25:11.242266126 +0100
-@@ -66,6 +66,10 @@
+--- a/tools/athstats.c
++++ b/tools/athstats.c
+@@ -65,6 +65,7 @@
  #undef ARRAY_SIZE
  #define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
-+#ifdef DOMULTI
 +#include "do_multi.h"
-+#endif
-+
  static const struct {
        u_int           phyerr;
-       const char*     desc;
-@@ -227,9 +231,20 @@
-       signalled = 1;
+@@ -228,7 +229,7 @@
  }
  
-+#ifdef DOMULTI
-+
-+int
-+athstats_init(int argc, char *argv[])
-+{
-+
-+#else
-+
  int
- main(int argc, char *argv[])
+-main(int argc, char *argv[])
++CMD(athstats)(int argc, char *argv[])
  {
-+
-+#endif
-+
  #ifdef __linux__
        const char *ifname = "wifi0";
- #else
-Index: madwifi-dfs-r3053/tools/do_multi.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ madwifi-dfs-r3053/tools/do_multi.c 2007-12-13 05:25:11.242266126 +0100
-@@ -0,0 +1,32 @@
+--- /dev/null
++++ b/tools/do_multi.c
+@@ -0,0 +1,33 @@
 +#include <string.h>
++#include <libgen.h>
 +#include "do_multi.h"
 +
 +int
@@ -283,12 +170,10 @@ Index: madwifi-dfs-r3053/tools/do_multi.c
 +
 +    return ret;
 +}
-Index: madwifi-dfs-r3053/tools/do_multi.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ madwifi-dfs-r3053/tools/do_multi.h 2007-12-13 05:25:11.246266355 +0100
-@@ -0,0 +1,10 @@
-+
+--- /dev/null
++++ b/tools/do_multi.h
+@@ -0,0 +1,15 @@
++#ifdef DO_MULTI
 +int a80211debug_init(int argc, char *argv[]);
 +int a80211stats_init(int argc, char *argv[]);
 +int athchans_init(int argc, char *argv[]);
@@ -298,27 +183,33 @@ Index: madwifi-dfs-r3053/tools/do_multi.h
 +int athstats_init(int argc, char *argv[]);
 +int wlanconfig_init(int argc, char *argv[]);
 +int athinfo_init(int argc, char *argv[]);
-Index: madwifi-dfs-r3053/tools/Makefile
-===================================================================
---- madwifi-dfs-r3053.orig/tools/Makefile      2007-12-13 05:25:10.842243330 +0100
-+++ madwifi-dfs-r3053/tools/Makefile   2007-12-13 05:25:11.246266355 +0100
-@@ -47,9 +47,12 @@
++
++#define CMD(name) name##_init
++#else
++#define CMD(name) main
++#endif
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -46,56 +46,55 @@
+ HAL=   $(TOP)/hal
  endif
  
++all: compile
  
 -ALL=  athstats 80211stats athkey athchans athctrl \
 +ALLPROGS=     athstats 80211stats athkey athchans athctrl \
        athdebug 80211debug wlanconfig ath_info
  
-+OBJS= $(patsubst %,%.o,$(ALLPROGS) do_multi)
-+ALL=  ${OBJS} madwifi_multi
-+
- all:  $(ALL)
+-all:  $(ALL)
++OBJS= $(patsubst %,%.o,$(ALLPROGS))
  
- INCS= -I. -I$(HAL) -I$(TOP) -I$(ATH_HAL)
-@@ -59,25 +62,31 @@
+-INCS= -I. -I$(HAL) -I$(TOP) -I$(ATH_HAL)
++INCS= -I. -I../ath -I$(HAL) -I$(TOP) -I$(ATH_HAL)
+ CFLAGS=       -g -O2 -Wall
+ ALL_CFLAGS= $(CFLAGS) $(INCS)
+ LDFLAGS=
  
- all:  $(ALL)
+-all:  $(ALL)
  
 -athstats: athstats.c
 -      $(CC) -o athstats $(ALL_CFLAGS) -I$(TOP)/ath $(LDFLAGS) athstats.c
@@ -338,84 +229,87 @@ Index: madwifi-dfs-r3053/tools/Makefile
 -      $(CC) -o 80211debug $(ALL_CFLAGS) $(LDFLAGS) 80211debug.c
 -ath_info: ath_info.c
 -      $(CC) -o ath_info $(CFLAGS) ath_info.c
--
-+athstats.o: athstats.c
-+      ${CC} -c -o athstats.o -DDOMULTI=1 ${ALL_CFLAGS} -I../ath athstats.c
-+80211stats.o: 80211stats.c
-+      ${CC} -c -o 80211stats.o -DDOMULTI=1 ${ALL_CFLAGS} 80211stats.c
-+ath_info.o: ath_info.c
-+      ${CC} -c -o ath_info.o -DDOMULTI=1 ${ALL_CFLAGS} ath_info.c
-+athkey.o: athkey.c
-+      ${CC} -c -o athkey.o -DDOMULTI=1 ${ALL_CFLAGS} athkey.c
-+athchans.o: athchans.c
-+      ${CC} -c -o athchans.o -DDOMULTI=1 ${ALL_CFLAGS} athchans.c
-+athctrl.o: athctrl.c
-+      ${CC} -c -o athctrl.o -DDOMULTI=1 ${ALL_CFLAGS} athctrl.c
-+athdebug.o: athdebug.c
-+      ${CC} -c -o athdebug.o -DDOMULTI=1 ${ALL_CFLAGS} athdebug.c
-+wlanconfig.o: wlanconfig.c
-+      ${CC} -c -o wlanconfig.o -DDOMULTI=1 ${ALL_CFLAGS} wlanconfig.c
-+80211debug.o: 80211debug.c
-+      ${CC} -c -o 80211debug.o -DDOMULTI=1 ${ALL_CFLAGS} 80211debug.c
-+do_multi.o: do_multi.c
-+      ${CC} -c -o do_multi.o -DDOMULTI=1 ${ALL_CFLAGS} do_multi.c
-+madwifi_multi: $(OBJS)
-+      ${CC} -o madwifi_multi ${LDFLAGS} ${OBJS}
-+      for i in athstats 80211stats athkey athchans athctrl athdebug wlanconfig 80211debug; do \
-+      ln -s -f madwifi_multi $$i; \
++ifneq ($(DO_MULTI),)
++ALL_CFLAGS += -DDO_MULTI=1
++%.o: %.c
++      ${CC} $(ALL_CFLAGS) -c -o $@  $<
++
++madwifi_multi: $(OBJS) do_multi.o
++      $(CC) -o $@ $^
++
++compile: madwifi_multi
++      for i in $(ALLPROGS); do \
++              ln -s -f madwifi_multi $$i; \
 +      done
++else
++$(ALLPROGS):
++      $(CC) $(ALL_CFLAGS) -o $@ $@.c
++
++compile: $(ALLPROGS)
++endif
  
  install: $(ALL) 
        install -d $(DESTDIR)$(BINDIR)
-Index: madwifi-dfs-r3053/tools/wlanconfig.c
-===================================================================
---- madwifi-dfs-r3053.orig/tools/wlanconfig.c  2007-12-13 05:25:10.850243788 +0100
-+++ madwifi-dfs-r3053/tools/wlanconfig.c       2007-12-13 05:25:11.246266355 +0100
-@@ -62,6 +62,10 @@
+-      for i in $(ALL); do \
++      for i in $(ALLPROGS) $(if $(DO_MULTI),madwifi_multi); do \
+               install $$i $(DESTDIR)$(BINDIR)/$$i; \
+-              $(STRIP) $(DESTDIR)$(BINDIR)/$$i; \
+       done
+       install -d $(DESTDIR)$(MANDIR)/man8
+       install -m 0644 man/*.8 $(DESTDIR)$(MANDIR)/man8
+       install $(TOP)/scripts/madwifi-unload $(DESTDIR)$(BINDIR)/madwifi-unload
+ uninstall:
+-      for i in $(ALL); do \
++      for i in $(ALLPROGS) $(if $(DO_MULTI),madwifi_multi); do \
+               rm -f $(DESTDIR)$(BINDIR)/$$i; \
+       done
+-      for i in $(ALL:=.8); do \
+-              rm -f $(DESTDIR)$(MANDIR)/man8/$$i; \
++      for i in $(ALLPROGS); do \
++              rm -f $(DESTDIR)$(MANDIR)/man8/$$i.8; \
+       done
+ clean:
+-      rm -f $(ALL) core a.out
++      rm -f $(ALLPROGS) madwifi_multi *.o core a.out
+--- a/tools/wlanconfig.c
++++ b/tools/wlanconfig.c
+@@ -61,6 +61,7 @@
+ #include "net80211/ieee80211.h"
  #include "net80211/ieee80211_crypto.h"
  #include "net80211/ieee80211_ioctl.h"
-+#ifdef DOMULTI
 +#include "do_multi.h"
-+#endif
-+
  /*
   * These are taken from ieee80211_node.h
-  */
-@@ -99,9 +103,19 @@
+@@ -100,7 +101,7 @@
  static int verbose = 0;
  
-+#ifdef DOMULTI
-+
-+int
-+wlanconfig_init(int argc, char *argv[])
-+{
-+
-+#else
-+
  int
- main(int argc, char *argv[])
+-main(int argc, char *argv[])
++CMD(wlanconfig)(int argc, char *argv[])
  {
-+
-+#endif
        const char *ifname, *cmd;
        unsigned char bnounit = 0;
-       char *if_base = NULL;
-Index: madwifi-dfs-r3053/tools/ath_info.c
-===================================================================
---- madwifi-dfs-r3053.orig/tools/ath_info.c    2007-12-13 05:25:10.858244244 +0100
-+++ madwifi-dfs-r3053/tools/ath_info.c 2007-12-13 05:25:11.246266355 +0100
-@@ -738,7 +738,12 @@
+--- a/tools/ath_info.c
++++ b/tools/ath_info.c
+@@ -98,6 +98,7 @@
+ #include <sys/mman.h>
+ #include <endian.h>
+ #include <byteswap.h>
++#include "do_multi.h"
+ #undef ARRAY_SIZE
+ #define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
+@@ -738,7 +739,8 @@
                "unlawful radio transmissions!\n\n");
  }
  
-+#ifdef DOMULTI
+-int main(int argc, char *argv[])
 +int
-+athinfo_init(int argc, char *argv[])
-+#else
- int main(int argc, char *argv[])
-+#endif
++CMD(athinfo)(int argc, char *argv[])
  {
        u_int32_t dev_addr;
        u_int16_t eeprom_header, srev, phy_rev_5ghz, phy_rev_2ghz;