dropbear: bump to 2020.79
[openwrt/staging/dedeckeh.git] / package / network / services / dropbear / patches / 901-bundled-libs-cflags.patch
index 033aee3a06b1acbfde7bb91d71fce9ecf03c9b54..2432b4ef72eae73f55575014284bdeae6562f18b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/libtomcrypt/makefile_include.mk
 +++ b/libtomcrypt/makefile_include.mk
-@@ -75,6 +75,13 @@ endif
+@@ -94,6 +94,13 @@ endif
  
  LTC_CFLAGS += -Wno-type-limits
  
@@ -14,7 +14,7 @@
  ifdef LTC_DEBUG
  $(info Debug build)
  # compile for DEBUGGING (required for ccmalloc checking!!!)
-@@ -102,6 +109,9 @@ endif
+@@ -121,6 +128,9 @@ endif
  endif # COMPILE_SMALL
  endif # COMPILE_DEBUG
  
@@ -26,8 +26,8 @@
  LTC_CFLAGS += -Wno-typedef-redefinition -Wno-tautological-compare -Wno-builtin-requires-header -Wno-missing-field-initializers
 --- a/libtommath/makefile_include.mk
 +++ b/libtommath/makefile_include.mk
-@@ -37,6 +37,9 @@ CFLAGS += -Wsystem-headers -Wdeclaration
- CFLAGS += -Wstrict-prototypes -Wpointer-arith
+@@ -70,6 +70,9 @@ else
+ LTM_CFLAGS += -Wsystem-headers
  endif
  
 +ifndef OPENWRT_BUILD
 +
  ifdef COMPILE_DEBUG
  #debug
- CFLAGS += -g3
-@@ -58,6 +61,9 @@ endif
+ LTM_CFLAGS += -g3
+@@ -90,6 +93,9 @@ endif
  endif # COMPILE_SIZE
- endif # COMPILE_DEBUG
  
 +  ### ! OPENWRT_BUILD
 +endif
 +
  ifneq ($(findstring clang,$(CC)),)
- CFLAGS += -Wno-typedef-redefinition -Wno-tautological-compare -Wno-builtin-requires-header
LTM_CFLAGS += -Wno-typedef-redefinition -Wno-tautological-compare -Wno-builtin-requires-header
  endif