hostapd: refresh patches
[openwrt/staging/wigyori.git] / package / network / services / hostapd / patches / 370-ap_sta_support.patch
index caa07f2299e2f09d5feedd42c7787a0c47142ae3..c81c841a43aa99de4ff0960cd13cd3a13fc3fe78 100644 (file)
@@ -1,17 +1,6 @@
 --- a/wpa_supplicant/Makefile
 +++ b/wpa_supplicant/Makefile
-@@ -26,6 +26,10 @@ CFLAGS += $(EXTRA_CFLAGS)
- CFLAGS += -I$(abspath ../src)
- CFLAGS += -I$(abspath ../src/utils)
-+ifdef MULTICALL
-+CFLAGS += -DMULTICALL
-+endif
-+
- -include .config
- -include $(if $(MULTICALL),../hostapd/.config)
-@@ -117,6 +121,8 @@ OBJS_c += ../src/utils/common.o
+@@ -108,6 +108,8 @@ OBJS_c += ../src/utils/common.o
  OBJS_c += ../src/common/cli.o
  OBJS += wmm_ac.o
  
@@ -30,7 +19,7 @@
  #include "drivers/driver.h"
  #include "eap_peer/eap.h"
  #include "wpa_supplicant_i.h"
-@@ -292,6 +293,10 @@ void calculate_update_time(const struct
+@@ -282,6 +283,10 @@ void calculate_update_time(const struct
  static void wpa_bss_copy_res(struct wpa_bss *dst, struct wpa_scan_res *src,
                             struct os_reltime *fetch_time)
  {
@@ -41,7 +30,7 @@
        dst->flags = src->flags;
        os_memcpy(dst->bssid, src->bssid, ETH_ALEN);
        dst->freq = src->freq;
-@@ -304,6 +309,15 @@ static void wpa_bss_copy_res(struct wpa_
+@@ -294,6 +299,15 @@ static void wpa_bss_copy_res(struct wpa_
        dst->est_throughput = src->est_throughput;
        dst->snr = src->snr;
  
@@ -59,7 +48,7 @@
  
 --- a/wpa_supplicant/bss.h
 +++ b/wpa_supplicant/bss.h
-@@ -81,6 +81,10 @@ struct wpa_bss {
+@@ -94,6 +94,10 @@ struct wpa_bss {
        u8 ssid[SSID_MAX_LEN];
        /** Length of SSID */
        size_t ssid_len;
                        break;
 --- a/wpa_supplicant/wpa_supplicant.c
 +++ b/wpa_supplicant/wpa_supplicant.c
-@@ -125,6 +125,55 @@ static void wpas_update_fils_connect_par
- #endif /* CONFIG_FILS && IEEE8021X_EAPOL */
+@@ -130,6 +130,54 @@ static void wpas_update_fils_connect_par
+ static void wpas_update_owe_connect_params(struct wpa_supplicant *wpa_s);
+ #endif /* CONFIG_OWE */
  
 +static int hostapd_stop(struct wpa_supplicant *wpa_s)
 +{
 +      }
 +      return 0;
 +}
-+
+ #ifdef CONFIG_WEP
  /* Configure default/group WEP keys for static WEP */
- int wpa_set_wep_keys(struct wpa_supplicant *wpa_s, struct wpa_ssid *ssid)
- {
-@@ -893,12 +942,16 @@ void wpa_supplicant_set_state(struct wpa
+@@ -1015,6 +1063,8 @@ void wpa_supplicant_set_state(struct wpa
  
                sme_sched_obss_scan(wpa_s, 1);
  
 +                      hostapd_reload(wpa_s, wpa_s->current_bss);
  #if defined(CONFIG_FILS) && defined(IEEE8021X_EAPOL)
                if (!fils_hlp_sent && ssid && ssid->eap.erp)
-                       wpas_update_fils_connect_params(wpa_s);
- #endif /* CONFIG_FILS && IEEE8021X_EAPOL */
+                       update_fils_connect_params = true;
+@@ -1025,6 +1075,8 @@ void wpa_supplicant_set_state(struct wpa
+ #endif /* CONFIG_OWE */
        } else if (state == WPA_DISCONNECTED || state == WPA_ASSOCIATING ||
                   state == WPA_ASSOCIATED) {
 +              if (wpa_s->hostapd)
                wpa_s->new_connection = 1;
                wpa_drv_set_operstate(wpa_s, 0);
  #ifndef IEEE8021X_EAPOL
-@@ -1920,6 +1973,8 @@ void wpa_supplicant_associate(struct wpa
-                       wpa_ssid_txt(ssid->ssid, ssid->ssid_len),
-                       ssid->id);
-               wpas_notify_mesh_group_started(wpa_s, ssid);
+@@ -2308,6 +2360,8 @@ void wpa_supplicant_associate(struct wpa
+                       return;
+               }
+               wpa_s->current_bss = bss;
 +              if (wpa_s->hostapd)
 +                      hostapd_reload(wpa_s, wpa_s->current_bss);
  #else /* CONFIG_MESH */
                wpa_msg(wpa_s, MSG_ERROR,
                        "mesh mode support not included in the build");
-@@ -5396,6 +5451,16 @@ static int wpa_supplicant_init_iface(str
+@@ -6650,6 +6704,16 @@ static int wpa_supplicant_init_iface(str
                           sizeof(wpa_s->bridge_ifname));
        }
  
 +      }
 +
        /* RSNA Supplicant Key Management - INITIALIZE */
-       eapol_sm_notify_portEnabled(wpa_s->eapol, FALSE);
-       eapol_sm_notify_portValid(wpa_s->eapol, FALSE);
-@@ -5717,6 +5782,11 @@ static void wpa_supplicant_deinit_iface(
+       eapol_sm_notify_portEnabled(wpa_s->eapol, false);
+       eapol_sm_notify_portValid(wpa_s->eapol, false);
+@@ -6987,6 +7051,11 @@ static void wpa_supplicant_deinit_iface(
        if (terminate)
                wpa_msg(wpa_s, MSG_INFO, WPA_EVENT_TERMINATING);
  
 +              wpa_s->hostapd = NULL;
 +      }
 +
-       if (wpa_s->ctrl_iface) {
-               wpa_supplicant_ctrl_iface_deinit(wpa_s->ctrl_iface);
-               wpa_s->ctrl_iface = NULL;
+       wpa_supplicant_ctrl_iface_deinit(wpa_s, wpa_s->ctrl_iface);
+       wpa_s->ctrl_iface = NULL;
 --- a/wpa_supplicant/wpa_supplicant_i.h
 +++ b/wpa_supplicant/wpa_supplicant_i.h
-@@ -101,6 +101,11 @@ struct wpa_interface {
+@@ -104,6 +104,11 @@ struct wpa_interface {
        const char *ifname;
  
        /**
         * bridge_ifname - Optional bridge interface name
         *
         * If the driver interface (ifname) is included in a Linux bridge
-@@ -513,6 +518,8 @@ struct wpa_supplicant {
+@@ -718,6 +723,8 @@ struct wpa_supplicant {
  #endif /* CONFIG_CTRL_IFACE_BINDER */
        char bridge_ifname[16];
  
        char *confname;
        char *confanother;
  
+--- a/hostapd/ctrl_iface.c
++++ b/hostapd/ctrl_iface.c
+@@ -2889,6 +2889,12 @@ static int hostapd_ctrl_iface_chan_switc
+               return 0;
+       }
++      if (os_strstr(pos, " auto-ht")) {
++              settings.freq_params.ht_enabled = iface->conf->ieee80211n;
++              settings.freq_params.vht_enabled = iface->conf->ieee80211ac;
++              settings.freq_params.he_enabled = iface->conf->ieee80211ax;
++      }
++
+       for (i = 0; i < iface->num_bss; i++) {
+               /* Save CHAN_SWITCH VHT and HE config */
+--- a/src/ap/beacon.c
++++ b/src/ap/beacon.c
+@@ -1791,11 +1791,6 @@ static int __ieee802_11_set_beacon(struc
+               return -1;
+       }
+-      if (hapd->csa_in_progress) {
+-              wpa_printf(MSG_ERROR, "Cannot set beacons during CSA period");
+-              return -1;
+-      }
+-
+       hapd->beacon_set_done = 1;
+       if (ieee802_11_build_ap_params(hapd, &params) < 0)
+--- a/wpa_supplicant/events.c
++++ b/wpa_supplicant/events.c
+@@ -4891,6 +4891,60 @@ static void wpas_event_unprot_beacon(str
+ }
++static void
++supplicant_ch_switch_started(struct wpa_supplicant *wpa_s,
++                          union wpa_event_data *data)
++{
++      char buf[256];
++      size_t len = sizeof(buf);
++      char *cmd = NULL;
++      int width = 20;
++      int ret;
++
++      if (!wpa_s->hostapd)
++              return;
++
++      wpa_msg(wpa_s, MSG_INFO, WPA_EVENT_CHANNEL_SWITCH
++              "count=%d freq=%d ht_enabled=%d ch_offset=%d ch_width=%s cf1=%d cf2=%d",
++              data->ch_switch.count,
++              data->ch_switch.freq,
++              data->ch_switch.ht_enabled,
++              data->ch_switch.ch_offset,
++              channel_width_to_string(data->ch_switch.ch_width),
++              data->ch_switch.cf1,
++              data->ch_switch.cf2);
++
++      switch (data->ch_switch.ch_width) {
++      case CHAN_WIDTH_20_NOHT:
++      case CHAN_WIDTH_20:
++              width = 20;
++              break;
++      case CHAN_WIDTH_40:
++              width = 40;
++              break;
++      case CHAN_WIDTH_80:
++              width = 80;
++              break;
++      case CHAN_WIDTH_160:
++      case CHAN_WIDTH_80P80:
++              width = 160;
++              break;
++      }
++
++      asprintf(&cmd, "CHAN_SWITCH %d %d sec_channel_offset=%d center_freq1=%d center_freq2=%d, bandwidth=%d auto-ht\n",
++              data->ch_switch.count - 1,
++              data->ch_switch.freq,
++              data->ch_switch.ch_offset,
++              data->ch_switch.cf1,
++              data->ch_switch.cf2,
++              width);
++      ret = wpa_ctrl_request(wpa_s->hostapd, cmd, os_strlen(cmd), buf, &len, NULL);
++      free(cmd);
++
++      if (ret < 0)
++              wpa_printf(MSG_ERROR, "\nFailed to reload hostapd AP interfaces\n");
++}
++
+ void supplicant_event(void *ctx, enum wpa_event_type event,
+                     union wpa_event_data *data)
+ {
+@@ -5206,8 +5260,10 @@ void supplicant_event(void *ctx, enum wp
+                       channel_width_to_string(data->ch_switch.ch_width),
+                       data->ch_switch.cf1,
+                       data->ch_switch.cf2);
+-              if (event == EVENT_CH_SWITCH_STARTED)
++              if (event == EVENT_CH_SWITCH_STARTED) {
++                      supplicant_ch_switch_started(wpa_s, data);
+                       break;
++              }
+               wpa_s->assoc_freq = data->ch_switch.freq;
+               wpa_s->current_ssid->frequency = data->ch_switch.freq;
+--- a/src/drivers/driver.h
++++ b/src/drivers/driver.h
+@@ -5837,6 +5837,7 @@ union wpa_event_data {
+       /**
+        * struct ch_switch
++       * @count: Count until channel switch activates
+        * @freq: Frequency of new channel in MHz
+        * @ht_enabled: Whether this is an HT channel
+        * @ch_offset: Secondary channel offset
+@@ -5845,6 +5846,7 @@ union wpa_event_data {
+        * @cf2: Center frequency 2
+        */
+       struct ch_switch {
++              int count;
+               int freq;
+               int ht_enabled;
+               int ch_offset;
+--- a/src/drivers/driver_nl80211_event.c
++++ b/src/drivers/driver_nl80211_event.c
+@@ -684,7 +684,7 @@ static void mlme_event_ch_switch(struct
+                                struct nlattr *ifindex, struct nlattr *freq,
+                                struct nlattr *type, struct nlattr *bw,
+                                struct nlattr *cf1, struct nlattr *cf2,
+-                               int finished)
++                               struct nlattr *count, int finished)
+ {
+       struct i802_bss *bss;
+       union wpa_event_data data;
+@@ -745,6 +745,8 @@ static void mlme_event_ch_switch(struct
+               data.ch_switch.cf1 = nla_get_u32(cf1);
+       if (cf2)
+               data.ch_switch.cf2 = nla_get_u32(cf2);
++      if (count)
++              data.ch_switch.count = nla_get_u32(count);
+       if (finished)
+               bss->freq = data.ch_switch.freq;
+@@ -3003,6 +3005,7 @@ static void do_process_drv_event(struct
+                                    tb[NL80211_ATTR_CHANNEL_WIDTH],
+                                    tb[NL80211_ATTR_CENTER_FREQ1],
+                                    tb[NL80211_ATTR_CENTER_FREQ2],
++                                   tb[NL80211_ATTR_CH_SWITCH_COUNT],
+                                    0);
+               break;
+       case NL80211_CMD_CH_SWITCH_NOTIFY:
+@@ -3013,6 +3016,7 @@ static void do_process_drv_event(struct
+                                    tb[NL80211_ATTR_CHANNEL_WIDTH],
+                                    tb[NL80211_ATTR_CENTER_FREQ1],
+                                    tb[NL80211_ATTR_CENTER_FREQ2],
++                                   NULL,
+                                    1);
+               break;
+       case NL80211_CMD_DISCONNECT: