hostapd: update to latest Git hostap_2_9-1238-gdd2daf0848ed
[openwrt/staging/luka.git] / package / network / services / hostapd / patches / 600-ubus_support.patch
index db037c6491669bfb350eb815bb44fd3ab2041a18..c4cf2a4cde4685e4e63910e215747672c51de841 100644 (file)
@@ -1,6 +1,6 @@
 --- a/hostapd/Makefile
 +++ b/hostapd/Makefile
-@@ -165,6 +165,11 @@ OBJS += ../src/common/hw_features_common
+@@ -167,6 +167,11 @@ OBJS += ../src/common/hw_features_common
  
  OBJS += ../src/eapol_auth/eapol_auth_sm.o
  
@@ -14,7 +14,7 @@
  CFLAGS += -O0 -fprofile-arcs -ftest-coverage
 --- a/src/ap/hostapd.h
 +++ b/src/ap/hostapd.h
-@@ -13,6 +13,7 @@
+@@ -17,6 +17,7 @@
  #include "utils/list.h"
  #include "ap_config.h"
  #include "drivers/driver.h"
  
  #define OCE_STA_CFON_ENABLED(hapd) \
        ((hapd->conf->oce & OCE_STA_CFON) && \
-@@ -136,6 +137,7 @@ struct hostapd_data {
+@@ -80,7 +81,7 @@ struct hapd_interfaces {
+ #ifdef CONFIG_CTRL_IFACE_UDP
+        unsigned char ctrl_iface_cookie[CTRL_IFACE_COOKIE_LEN];
+ #endif /* CONFIG_CTRL_IFACE_UDP */
+-
++      struct ubus_object ubus;
+ };
+ enum hostapd_chan_status {
+@@ -154,6 +155,7 @@ struct hostapd_data {
        struct hostapd_iface *iface;
        struct hostapd_config *iconf;
        struct hostapd_bss_config *conf;
@@ -30,7 +39,7 @@
        int interface_added; /* virtual interface added for this BSS */
        unsigned int started:1;
        unsigned int disabled:1;
-@@ -547,6 +549,7 @@ hostapd_alloc_bss_data(struct hostapd_if
+@@ -588,6 +590,7 @@ hostapd_alloc_bss_data(struct hostapd_if
                       struct hostapd_bss_config *bss);
  int hostapd_setup_interface(struct hostapd_iface *iface);
  int hostapd_setup_interface_complete(struct hostapd_iface *iface, int err);
  struct hostapd_iface * hostapd_alloc_iface(void);
 --- a/src/ap/hostapd.c
 +++ b/src/ap/hostapd.c
-@@ -373,6 +373,7 @@ static void hostapd_free_hapd_data(struc
-       hapd->started = 0;
+@@ -391,6 +391,7 @@ static void hostapd_free_hapd_data(struc
+       hapd->beacon_set_done = 0;
  
        wpa_printf(MSG_DEBUG, "%s(%s)", __func__, hapd->conf->iface);
 +      hostapd_ubus_free_bss(hapd);
-       iapp_deinit(hapd->iapp);
-       hapd->iapp = NULL;
        accounting_deinit(hapd);
-@@ -1295,6 +1296,8 @@ static int hostapd_setup_bss(struct host
+       hostapd_deinit_wpa(hapd);
+       vlan_deinit(hapd);
+@@ -1392,6 +1393,8 @@ static int hostapd_setup_bss(struct host
        if (hapd->driver && hapd->driver->set_operstate)
                hapd->driver->set_operstate(hapd->drv_priv, 1);
  
        return 0;
  }
  
-@@ -1709,7 +1712,7 @@ static enum nr_chan_width hostapd_get_nr
- #endif /* NEED_AP_MLME */
--static void hostapd_set_own_neighbor_report(struct hostapd_data *hapd)
-+void hostapd_set_own_neighbor_report(struct hostapd_data *hapd)
- {
- #ifdef NEED_AP_MLME
-       u16 capab = hostapd_own_capab_info(hapd);
-@@ -1930,6 +1933,7 @@ static int hostapd_setup_interface_compl
+@@ -1967,6 +1970,7 @@ static int hostapd_setup_interface_compl
        if (err)
                goto fail;
  
 +      hostapd_ubus_add_iface(iface);
        wpa_printf(MSG_DEBUG, "Completing interface initialization");
-       if (iface->conf->channel) {
+       if (iface->freq) {
  #ifdef NEED_AP_MLME
-@@ -2110,6 +2114,7 @@ dfs_offload:
+@@ -2157,6 +2161,7 @@ dfs_offload:
  
  fail:
        wpa_printf(MSG_ERROR, "Interface initialization failed");
@@ -82,7 +82,7 @@
        hostapd_set_state(iface, HAPD_IFACE_DISABLED);
        wpa_msg(hapd->msg_ctx, MSG_INFO, AP_EVENT_DISABLED);
  #ifdef CONFIG_FST
-@@ -2576,6 +2581,7 @@ void hostapd_interface_deinit_free(struc
+@@ -2630,6 +2635,7 @@ void hostapd_interface_deinit_free(struc
                   (unsigned int) iface->conf->num_bss);
        driver = iface->bss[0]->driver;
        drv_priv = iface->bss[0]->drv_priv;
                   __func__, driver, drv_priv);
 --- a/src/ap/ieee802_11.c
 +++ b/src/ap/ieee802_11.c
-@@ -1759,12 +1759,13 @@ ieee802_11_set_radius_info(struct hostap
- static void handle_auth(struct hostapd_data *hapd,
--                      const struct ieee80211_mgmt *mgmt, size_t len)
-+                      const struct ieee80211_mgmt *mgmt, size_t len,
-+                      struct hostapd_frame_info *fi)
- {
+@@ -2252,13 +2252,18 @@ static void handle_auth(struct hostapd_d
        u16 auth_alg, auth_transaction, status_code;
        u16 resp = WLAN_STATUS_SUCCESS;
        struct sta_info *sta = NULL;
 +      int res, reply_res, ubus_resp;
        u16 fc;
        const u8 *challenge = NULL;
-       u32 session_timeout, acct_interim_interval;
-@@ -1775,6 +1776,11 @@ static void handle_auth(struct hostapd_d
-       char *identity = NULL;
-       char *radius_cui = NULL;
+       u8 resp_ies[2 + WLAN_AUTH_CHALLENGE_LEN];
+       size_t resp_ies_len = 0;
        u16 seq_ctrl;
+       struct radius_sta rad_info;
 +      struct hostapd_ubus_request req = {
 +              .type = HOSTAPD_UBUS_AUTH_REQ,
 +              .mgmt_frame = mgmt,
-+              .frame_info = fi,
++              .ssi_signal = rssi,
 +      };
  
        if (len < IEEE80211_HDRLEN + sizeof(mgmt->u.auth)) {
                wpa_printf(MSG_INFO, "handle_auth - too short payload (len=%lu)",
-@@ -1935,6 +1941,13 @@ static void handle_auth(struct hostapd_d
+@@ -2418,6 +2423,13 @@ static void handle_auth(struct hostapd_d
                resp = WLAN_STATUS_UNSPECIFIED_FAILURE;
                goto fail;
        }
        if (res == HOSTAPD_ACL_PENDING)
                return;
  
-@@ -3287,12 +3300,12 @@ void fils_hlp_timeout(void *eloop_ctx, v
- static void handle_assoc(struct hostapd_data *hapd,
-                        const struct ieee80211_mgmt *mgmt, size_t len,
--                       int reassoc)
-+                       int reassoc, struct hostapd_frame_info *fi)
- {
-       u16 capab_info, listen_interval, seq_ctrl, fc;
-       u16 resp = WLAN_STATUS_SUCCESS, reply_res;
+@@ -4078,7 +4090,7 @@ static void handle_assoc(struct hostapd_
+       int resp = WLAN_STATUS_SUCCESS;
+       u16 reply_res;
        const u8 *pos;
 -      int left, i;
 +      int left, i, ubus_resp;
        struct sta_info *sta;
        u8 *tmp = NULL;
-       struct hostapd_sta_wpa_psk_short *psk = NULL;
-@@ -3301,6 +3314,11 @@ static void handle_assoc(struct hostapd_
  #ifdef CONFIG_FILS
-       int delay_assoc = 0;
+@@ -4291,6 +4303,11 @@ static void handle_assoc(struct hostapd_
+               left = res;
+       }
  #endif /* CONFIG_FILS */
 +      struct hostapd_ubus_request req = {
 +              .type = HOSTAPD_UBUS_ASSOC_REQ,
 +              .mgmt_frame = mgmt,
-+              .frame_info = fi,
++              .ssi_signal = rssi,
 +      };
  
-       if (len < IEEE80211_HDRLEN + (reassoc ? sizeof(mgmt->u.reassoc_req) :
-                                     sizeof(mgmt->u.assoc_req))) {
-@@ -3472,6 +3490,14 @@ static void handle_assoc(struct hostapd_
-       }
- #endif /* CONFIG_MBO */
+       /* followed by SSID and Supported rates; and HT capabilities if 802.11n
+        * is used */
+@@ -4455,6 +4472,14 @@ static void handle_assoc(struct hostapd_
+                                           pos, left, rssi, omit_rsnxe);
+       os_free(tmp);
  
 +      ubus_resp = hostapd_ubus_handle_event(hapd, &req);
 +      if (ubus_resp) {
 +      }
 +
        /*
-        * sta->capability is used in check_assoc_ies() for RRM enabled
-        * capability element.
-@@ -3685,6 +3711,7 @@ static void handle_disassoc(struct hosta
+        * Remove the station in case tranmission of a success response fails
+        * (the STA was added associated to the driver) or if the station was
+@@ -4482,6 +4507,7 @@ static void handle_disassoc(struct hosta
        wpa_printf(MSG_DEBUG, "disassocation: STA=" MACSTR " reason_code=%d",
                   MAC2STR(mgmt->sa),
                   le_to_host16(mgmt->u.disassoc.reason_code));
  
        sta = ap_get_sta(hapd, mgmt->sa);
        if (sta == NULL) {
-@@ -3750,6 +3777,8 @@ static void handle_deauth(struct hostapd
+@@ -4548,6 +4574,8 @@ static void handle_deauth(struct hostapd
                " reason_code=%d",
                MAC2STR(mgmt->sa), le_to_host16(mgmt->u.deauth.reason_code));
  
        sta = ap_get_sta(hapd, mgmt->sa);
        if (sta == NULL) {
                wpa_msg(hapd->msg_ctx, MSG_DEBUG, "Station " MACSTR " trying "
-@@ -4077,7 +4106,7 @@ int ieee802_11_mgmt(struct hostapd_data
-       if (stype == WLAN_FC_STYPE_PROBE_REQ) {
--              handle_probe_req(hapd, mgmt, len, ssi_signal);
-+              handle_probe_req(hapd, mgmt, len, fi);
-               return 1;
-       }
-@@ -4097,17 +4126,17 @@ int ieee802_11_mgmt(struct hostapd_data
-       switch (stype) {
-       case WLAN_FC_STYPE_AUTH:
-               wpa_printf(MSG_DEBUG, "mgmt::auth");
--              handle_auth(hapd, mgmt, len);
-+              handle_auth(hapd, mgmt, len, fi);
-               ret = 1;
-               break;
-       case WLAN_FC_STYPE_ASSOC_REQ:
-               wpa_printf(MSG_DEBUG, "mgmt::assoc_req");
--              handle_assoc(hapd, mgmt, len, 0);
-+              handle_assoc(hapd, mgmt, len, 0, fi);
-               ret = 1;
-               break;
-       case WLAN_FC_STYPE_REASSOC_REQ:
-               wpa_printf(MSG_DEBUG, "mgmt::reassoc_req");
--              handle_assoc(hapd, mgmt, len, 1);
-+              handle_assoc(hapd, mgmt, len, 1, fi);
-               ret = 1;
-               break;
-       case WLAN_FC_STYPE_DISASSOC:
 --- a/src/ap/beacon.c
 +++ b/src/ap/beacon.c
-@@ -725,7 +725,7 @@ void sta_track_claim_taxonomy_info(struc
- void handle_probe_req(struct hostapd_data *hapd,
-                     const struct ieee80211_mgmt *mgmt, size_t len,
--                    int ssi_signal)
-+                    struct hostapd_frame_info *fi)
- {
-       u8 *resp;
-       struct ieee802_11_elems elems;
-@@ -734,6 +734,7 @@ void handle_probe_req(struct hostapd_dat
-       size_t i, resp_len;
-       int noack;
-       enum ssid_match_result res;
-+      int ssi_signal = fi->ssi_signal;
-       int ret;
+@@ -810,6 +810,12 @@ void handle_probe_req(struct hostapd_dat
        u16 csa_offs[2];
        size_t csa_offs_len;
-@@ -742,6 +743,12 @@ void handle_probe_req(struct hostapd_dat
-       struct hostapd_sta_wpa_psk_short *psk = NULL;
-       char *identity = NULL;
-       char *radius_cui = NULL;
+       struct radius_sta rad_info;
 +      struct hostapd_ubus_request req = {
 +              .type = HOSTAPD_UBUS_PROBE_REQ,
 +              .mgmt_frame = mgmt,
-+              .frame_info = fi,
++              .ssi_signal = ssi_signal,
 +              .elems = &elems,
 +      };
  
        if (len < IEEE80211_HDRLEN)
                return;
-@@ -919,6 +926,12 @@ void handle_probe_req(struct hostapd_dat
+@@ -992,6 +998,12 @@ void handle_probe_req(struct hostapd_dat
        }
  #endif /* CONFIG_P2P */
  
        /* TODO: verify that supp_rates contains at least one matching rate
         * with AP configuration */
  
---- a/src/ap/beacon.h
-+++ b/src/ap/beacon.h
-@@ -14,7 +14,7 @@ struct ieee80211_mgmt;
- void handle_probe_req(struct hostapd_data *hapd,
-                     const struct ieee80211_mgmt *mgmt, size_t len,
--                    int ssi_signal);
-+                    struct hostapd_frame_info *fi);
- int ieee802_11_set_beacon(struct hostapd_data *hapd);
- int ieee802_11_set_beacons(struct hostapd_iface *iface);
- int ieee802_11_update_beacons(struct hostapd_iface *iface);
 --- a/src/ap/drv_callbacks.c
 +++ b/src/ap/drv_callbacks.c
-@@ -116,6 +116,10 @@ int hostapd_notif_assoc(struct hostapd_d
+@@ -119,6 +119,10 @@ int hostapd_notif_assoc(struct hostapd_d
        u16 reason = WLAN_REASON_UNSPECIFIED;
-       u16 status = WLAN_STATUS_SUCCESS;
+       int status = WLAN_STATUS_SUCCESS;
        const u8 *p2p_dev_addr = NULL;
 +      struct hostapd_ubus_request req = {
 +              .type = HOSTAPD_UBUS_ASSOC_REQ,
  
        if (addr == NULL) {
                /*
-@@ -195,6 +199,12 @@ int hostapd_notif_assoc(struct hostapd_d
+@@ -211,6 +215,12 @@ int hostapd_notif_assoc(struct hostapd_d
                goto fail;
        }
  
                wpabuf_free(sta->p2p_ie);
 --- a/src/ap/sta_info.c
 +++ b/src/ap/sta_info.c
-@@ -416,6 +416,7 @@ void ap_handle_timer(void *eloop_ctx, vo
+@@ -423,6 +423,7 @@ void ap_handle_timer(void *eloop_ctx, vo
                               HOSTAPD_LEVEL_INFO, "deauthenticated due to "
                               "local deauth request");
                ap_free_sta(hapd, sta);
                return;
        }
  
-@@ -563,6 +564,7 @@ skip_poll:
+@@ -578,6 +579,7 @@ skip_poll:
                        hapd, sta,
                        WLAN_REASON_PREV_AUTH_NOT_VALID);
                ap_free_sta(hapd, sta);
                break;
        }
  }
-@@ -1224,6 +1226,7 @@ void ap_sta_set_authorized(struct hostap
-                                         buf, ip_addr);
+@@ -1293,6 +1295,7 @@ void ap_sta_set_authorized(struct hostap
+                                         buf, ip_addr, keyid_buf);
        } else {
                wpa_msg(hapd->msg_ctx, MSG_INFO, AP_STA_DISCONNECTED "%s", buf);
 +              hostapd_ubus_notify(hapd, "disassoc", sta->addr);
                    hapd->msg_ctx_parent != hapd->msg_ctx)
 --- a/src/ap/wpa_auth_glue.c
 +++ b/src/ap/wpa_auth_glue.c
-@@ -177,6 +177,7 @@ static void hostapd_wpa_auth_psk_failure
+@@ -251,6 +251,7 @@ static void hostapd_wpa_auth_psk_failure
        struct hostapd_data *hapd = ctx;
        wpa_msg(hapd->msg_ctx, MSG_INFO, AP_STA_POSSIBLE_PSK_MISMATCH MACSTR,
                MAC2STR(addr));
  
 --- a/wpa_supplicant/Makefile
 +++ b/wpa_supplicant/Makefile
-@@ -189,6 +189,12 @@ ifdef CONFIG_EAPOL_TEST
+@@ -190,6 +190,12 @@ ifdef CONFIG_EAPOL_TEST
  CFLAGS += -Werror -DEAPOL_TEST
  endif
  
  ifdef CONFIG_CODE_COVERAGE
  CFLAGS += -O0 -fprofile-arcs -ftest-coverage
  LIBS += -lgcov
-@@ -915,6 +921,9 @@ endif
- ifdef CONFIG_IEEE80211AX
- OBJS += ../src/ap/ieee802_11_he.o
+@@ -877,6 +883,9 @@ OBJS += ../src/pae/ieee802_1x_secy_ops.o
+ ifdef CONFIG_AP
+ OBJS += ../src/ap/wpa_auth_kay.o
  endif
 +ifdef CONFIG_UBUS
 +OBJS += ../src/ap/ubus.o
 +endif
  endif
- ifdef CONFIG_WNM_AP
- CFLAGS += -DCONFIG_WNM_AP
+ ifdef CONFIG_IEEE8021X_EAPOL
 --- a/wpa_supplicant/wpa_supplicant.c
 +++ b/wpa_supplicant/wpa_supplicant.c
-@@ -6080,6 +6080,8 @@ struct wpa_supplicant * wpa_supplicant_a
+@@ -6771,6 +6771,8 @@ struct wpa_supplicant * wpa_supplicant_a
        }
  #endif /* CONFIG_P2P */
  
        return wpa_s;
  }
  
-@@ -6106,6 +6108,8 @@ int wpa_supplicant_remove_iface(struct w
+@@ -6797,6 +6799,8 @@ int wpa_supplicant_remove_iface(struct w
        struct wpa_supplicant *parent = wpa_s->parent;
  #endif /* CONFIG_MESH */
  
        /* Remove interface from the global list of interfaces */
        prev = global->ifaces;
        if (prev == wpa_s) {
+@@ -7100,8 +7104,12 @@ int wpa_supplicant_run(struct wpa_global
+       eloop_register_signal_terminate(wpa_supplicant_terminate, global);
+       eloop_register_signal_reconfig(wpa_supplicant_reconfig, global);
++      wpas_ubus_add(global);
++
+       eloop_run();
++      wpas_ubus_free(global);
++
+       return 0;
+ }
 --- a/wpa_supplicant/wpa_supplicant_i.h
 +++ b/wpa_supplicant/wpa_supplicant_i.h
 @@ -17,6 +17,7 @@
  
  extern const char *const wpa_supplicant_version;
  extern const char *const wpa_supplicant_license;
-@@ -500,6 +501,7 @@ struct wpa_supplicant {
+@@ -310,6 +311,8 @@ struct wpa_global {
+ #endif /* CONFIG_WIFI_DISPLAY */
+       struct psk_list_entry *add_psk; /* From group formation */
++
++      struct ubus_object ubus_global;
+ };
+@@ -520,6 +523,7 @@ struct wpa_supplicant {
        unsigned char own_addr[ETH_ALEN];
        unsigned char perm_addr[ETH_ALEN];
        char ifname[100];
        if (wpa_s->conf->wps_cred_processing == 1)
                return 0;
  
+--- a/hostapd/main.c
++++ b/hostapd/main.c
+@@ -892,6 +892,7 @@ int main(int argc, char *argv[])
+       }
+       hostapd_global_ctrl_iface_init(&interfaces);
++      hostapd_ubus_add(&interfaces);
+       if (hostapd_global_run(&interfaces, daemonize, pid_file)) {
+               wpa_printf(MSG_ERROR, "Failed to start eloop");
+@@ -901,6 +902,7 @@ int main(int argc, char *argv[])
+       ret = 0;
+  out:
++      hostapd_ubus_free(&interfaces);
+       hostapd_global_ctrl_iface_deinit(&interfaces);
+       /* Deinitialize all interfaces */
+       for (i = 0; i < interfaces.count; i++) {
+--- a/wpa_supplicant/main.c
++++ b/wpa_supplicant/main.c
+@@ -203,7 +203,7 @@ int main(int argc, char *argv[])
+       for (;;) {
+               c = getopt(argc, argv,
+-                         "b:Bc:C:D:de:f:g:G:hH:i:I:KLMm:No:O:p:P:qsTtuv::W");
++                         "b:Bc:C:D:de:f:g:G:hH:i:I:KLMm:nNo:O:p:P:qsTtuv::W");
+               if (c < 0)
+                       break;
+               switch (c) {
+@@ -271,6 +271,9 @@ int main(int argc, char *argv[])
+                       params.conf_p2p_dev = optarg;
+                       break;
+ #endif /* CONFIG_P2P */
++              case 'n':
++                      iface_count = 0;
++                      break;
+               case 'o':
+                       params.override_driver = optarg;
+                       break;
+--- a/src/ap/rrm.c
++++ b/src/ap/rrm.c
+@@ -89,6 +89,9 @@ static void hostapd_handle_beacon_report
+               return;
+       wpa_msg(hapd->msg_ctx, MSG_INFO, BEACON_RESP_RX MACSTR " %u %02x %s",
+               MAC2STR(addr), token, rep_mode, report);
++      if (len < sizeof(struct rrm_measurement_beacon_report))
++              return;
++      hostapd_ubus_notify_beacon_report(hapd, addr, token, rep_mode, (struct rrm_measurement_beacon_report*) pos, len);
+ }