iperf: Allow enabling multicast support
[openwrt/staging/jow.git] / package / network / utils / iperf / Makefile
index 33d00b43d75e886a6d1a9cd68ea370307c8a238c..5c84e1617d0e8a86f70681234d4db7dc988e99df 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iperf
 PKG_VERSION:=2.0.13
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_HASH:=c88adec966096a81136dda91b4bd19c27aae06df4d45a7f547a8e50d723778ad
@@ -20,6 +20,8 @@ PKG_LICENSE:=BSD-3-Clause
 
 PKG_BUILD_PARALLEL:=1
 
+PGK_CONFIG_DEPENDS:=IPERF_ENABLE_MULTICAST
+
 include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 
@@ -37,8 +39,19 @@ define Package/iperf/description
  characteristics.
 endef
 
+define Package/iperf/config
+       config IPERF_ENABLE_MULTICAST
+               depends on PACKAGE_iperf
+               bool "Enable multicast support"
+endef
+
+
 TARGET_CFLAGS += -D_GNU_SOURCE
+ifeq ($(CONFIG_IPERF_ENABLE_MULTICAST),y)
+CONFIGURE_ARGS += --enable-multicast
+else
 CONFIGURE_ARGS += --disable-multicast
+endif
 
 ifeq ($(CONFIG_IPV6),)
        CONFIGURE_ARGS += --disable-ipv6