iw: Update to version 5.8
[openwrt/staging/dedeckeh.git] / package / network / utils / iw / patches / 200-reduce_size.patch
index 2e31cf2ae5c192a9c402246bc77d7631d5649e3c..24eb96537b0f96da473a855af0969720de023b51 100644 (file)
@@ -1,45 +1,32 @@
---- a/Makefile
-+++ b/Makefile
-@@ -16,8 +16,8 @@ CFLAGS += -Wall -Wundef -Wstrict-prototy
- OBJS = iw.o genl.o event.o info.o phy.o \
-       interface.o ibss.o station.o survey.o util.o ocb.o \
-       mesh.o mpath.o mpp.o scan.o reg.o version.o \
--      reason.o status.o connect.o link.o offch.o ps.o cqm.o \
--      bitrate.o wowlan.o coalesce.o roc.o p2p.o vendor.o
-+      reason.o status.o link.o offch.o ps.o cqm.o \
-+      bitrate.o vendor.o
- OBJS += sections.o
- OBJS-$(HWSIM) += hwsim.o
 --- a/event.c
 +++ b/event.c
-@@ -342,6 +342,7 @@ static int print_event(struct nl_msg *ms
+@@ -944,6 +944,7 @@ static int print_event(struct nl_msg *ms
        }
  
        switch (gnlh->cmd) {
-+#if 0
++#ifdef IW_FULL
        case NL80211_CMD_NEW_WIPHY:
                printf("renamed to %s\n", nla_get_string(tb[NL80211_ATTR_WIPHY_NAME]));
                break;
-@@ -376,6 +377,7 @@ static int print_event(struct nl_msg *ms
+@@ -979,6 +980,7 @@ static int print_event(struct nl_msg *ms
        case NL80211_CMD_SCHED_SCAN_RESULTS:
                printf("got scheduled scan results\n");
                break;
 +#endif
+       case NL80211_CMD_WIPHY_REG_CHANGE:
        case NL80211_CMD_REG_CHANGE:
-               printf("regulatory domain change: ");
-@@ -454,6 +456,7 @@ static int print_event(struct nl_msg *ms
+               if (gnlh->cmd == NL80211_CMD_WIPHY_REG_CHANGE)
+@@ -1061,6 +1063,7 @@ static int print_event(struct nl_msg *ms
                mac_addr_n2a(macbuf, nla_data(tb[NL80211_ATTR_MAC]));
                printf("del station %s\n", macbuf);
                break;
-+#if 0
++#ifdef IW_FULL
        case NL80211_CMD_JOIN_IBSS:
                mac_addr_n2a(macbuf, nla_data(tb[NL80211_ATTR_MAC]));
                printf("IBSS %s joined\n", macbuf);
-@@ -610,9 +613,9 @@ static int print_event(struct nl_msg *ms
-       case NL80211_CMD_DEL_WIPHY:
-               printf("delete wiphy\n");
+@@ -1254,9 +1257,9 @@ static int print_event(struct nl_msg *ms
+       case NL80211_CMD_CH_SWITCH_NOTIFY:
+               parse_ch_switch_notify(tb, gnlh->cmd);
                break;
 +#endif
        default:
  
 --- a/info.c
 +++ b/info.c
-@@ -217,6 +217,7 @@ next:
+@@ -167,6 +167,7 @@ static int print_phy_handler(struct nl_m
+                           tb_band[NL80211_BAND_ATTR_VHT_MCS_SET])
+                               print_vht_info(nla_get_u32(tb_band[NL80211_BAND_ATTR_VHT_CAPA]),
+                                              nla_data(tb_band[NL80211_BAND_ATTR_VHT_MCS_SET]));
++#ifdef IW_FULL
+                       if (tb_band[NL80211_BAND_ATTR_IFTYPE_DATA]) {
+                               struct nlattr *nl_iftype;
+                               int rem_band;
+@@ -174,6 +175,7 @@ static int print_phy_handler(struct nl_m
+                               nla_for_each_nested(nl_iftype, tb_band[NL80211_BAND_ATTR_IFTYPE_DATA], rem_band)
+                                       print_he_info(nl_iftype);
+                       }
++#endif
+                       if (tb_band[NL80211_BAND_ATTR_FREQS]) {
+                               if (!band_had_freq) {
+                                       printf("\t\tFrequencies:\n");
+@@ -216,6 +218,7 @@ next:
                                }
                        }
  
-+#if 0
++#ifdef IW_FULL
                        if (tb_band[NL80211_BAND_ATTR_RATES]) {
                        printf("\t\tBitrates (non-HT):\n");
                        nla_for_each_nested(nl_rate, tb_band[NL80211_BAND_ATTR_RATES], rem_rate) {
-@@ -233,6 +234,7 @@ next:
+@@ -232,6 +235,7 @@ next:
                                printf("\n");
                        }
                        }
                }
        }
  
-@@ -298,6 +300,7 @@ next:
+@@ -297,6 +301,7 @@ next:
                printf("\tCoverage class: %d (up to %dm)\n", coverage, 450 * coverage);
        }
  
-+#if 0
++#ifdef IW_FULL
        if (tb_msg[NL80211_ATTR_CIPHER_SUITES]) {
                int num = nla_len(tb_msg[NL80211_ATTR_CIPHER_SUITES]) / sizeof(__u32);
                int i;
-@@ -309,6 +312,7 @@ next:
+@@ -308,6 +313,7 @@ next:
                                        cipher_name(ciphers[i]));
                }
        }
  
        if (tb_msg[NL80211_ATTR_WIPHY_ANTENNA_AVAIL_TX] &&
            tb_msg[NL80211_ATTR_WIPHY_ANTENNA_AVAIL_RX])
-@@ -328,11 +332,13 @@ next:
+@@ -327,11 +333,13 @@ next:
                        printf("\t\t * %s\n", iftype_name(nla_type(nl_mode)));
        }
  
-+#if 0
++#ifdef IW_FULL
        if (tb_msg[NL80211_ATTR_SOFTWARE_IFTYPES]) {
                printf("\tsoftware interface modes (can always be added):\n");
                nla_for_each_nested(nl_mode, tb_msg[NL80211_ATTR_SOFTWARE_IFTYPES], rem_mode)
  
        if (tb_msg[NL80211_ATTR_INTERFACE_COMBINATIONS]) {
                struct nlattr *nl_combi;
-@@ -429,6 +435,7 @@ broken_combination:
+@@ -428,6 +436,7 @@ broken_combination:
                        printf("\tinterface combinations are not supported\n");
        }
  
-+#if 0
++#ifdef IW_FULL
        if (tb_msg[NL80211_ATTR_SUPPORTED_COMMANDS]) {
                printf("\tSupported commands:\n");
                nla_for_each_nested(nl_cmd, tb_msg[NL80211_ATTR_SUPPORTED_COMMANDS], rem_cmd)
-@@ -526,6 +533,7 @@ broken_combination:
+@@ -525,6 +534,7 @@ broken_combination:
                                printf("\t\t * wake up on TCP connection\n");
                }
        }
  
        if (tb_msg[NL80211_ATTR_ROAM_SUPPORT])
                printf("\tDevice supports roaming.\n");
-@@ -564,6 +572,7 @@ broken_combination:
+@@ -563,6 +573,7 @@ broken_combination:
                }
        }
  
-+#if 0
++#ifdef IW_FULL
        if (tb_msg[NL80211_ATTR_FEATURE_FLAGS]) {
                unsigned int features = nla_get_u32(tb_msg[NL80211_ATTR_FEATURE_FLAGS]);
  
-@@ -622,6 +631,7 @@ broken_combination:
-               if (features & NL80211_FEATURE_TDLS_CHANNEL_SWITCH)
-                       printf("\tDevice supports TDLS channel switching\n");
+@@ -627,6 +638,7 @@ broken_combination:
+               if (features & NL80211_FEATURE_ND_RANDOM_MAC_ADDR)
+                       printf("\tDevice supports randomizing MAC-addr in net-detect scans.\n");
        }
 +#endif
  
-       if (tb_msg[NL80211_ATTR_EXT_FEATURES]) {
-               struct nlattr *tb = tb_msg[NL80211_ATTR_EXT_FEATURES];
-@@ -678,6 +688,7 @@ TOPLEVEL(list, NULL, NL80211_CMD_GET_WIP
+       if (tb_msg[NL80211_ATTR_TDLS_SUPPORT])
+               printf("\tDevice supports T-DLS.\n");
+@@ -762,6 +774,7 @@ TOPLEVEL(list, NULL, NL80211_CMD_GET_WIP
         "List all wireless devices and their capabilities.");
  TOPLEVEL(phy, NULL, NL80211_CMD_GET_WIPHY, NLM_F_DUMP, CIB_NONE, handle_info, NULL);
  
-+#if 0
++#ifdef IW_FULL
  static int handle_commands(struct nl80211_state *state, struct nl_msg *msg,
                           int argc, char **argv, enum id_input id)
  {
-@@ -689,6 +700,7 @@ static int handle_commands(struct nl8021
+@@ -773,6 +786,7 @@ static int handle_commands(struct nl8021
  }
  TOPLEVEL(commands, NULL, NL80211_CMD_GET_WIPHY, 0, CIB_NONE, handle_commands,
         "list all known commands and their decimal & hex value");
  {
 --- a/scan.c
 +++ b/scan.c
-@@ -1147,6 +1147,7 @@ static void print_ht_op(const uint8_t ty
+@@ -1297,6 +1297,9 @@ static void print_ht_op(const uint8_t ty
        printf("\t\t * secondary channel offset: %s\n",
                ht_secondary_offset[data[1] & 0x3]);
        printf("\t\t * STA channel width: %s\n", sta_chan_width[(data[1] & 0x4)>>2]);
++#ifndef IW_FULL
 +      return;
++#endif
        printf("\t\t * RIFS: %d\n", (data[1] & 0x8)>>3);
        printf("\t\t * HT protection: %s\n", protection[data[2] & 0x3]);
        printf("\t\t * non-GF present: %d\n", (data[2] & 0x4) >> 2);
-@@ -1380,6 +1381,13 @@ static void print_ie(const struct ie_pri
+@@ -1707,6 +1710,14 @@ static void print_ie(const struct ie_pri
  
  static const struct ie_print ieprinters[] = {
        [0] = { "SSID", print_ssid, 0, 32, BIT(PRINT_SCAN) | BIT(PRINT_LINK), },
 +      [48] = { "RSN", print_rsn, 2, 255, BIT(PRINT_SCAN), },
 +      [61] = { "HT operation", print_ht_op, 22, 22, BIT(PRINT_SCAN), },
 +      [62] = { "Secondary Channel Offset", print_secchan_offs, 1, 1, BIT(PRINT_SCAN), },
++      [114] = { "MESH ID", print_ssid, 0, 32, BIT(PRINT_SCAN) | BIT(PRINT_LINK), },
 +      [191] = { "VHT capabilities", print_vht_capa, 12, 255, BIT(PRINT_SCAN), },
 +      [192] = { "VHT operation", print_vht_oper, 5, 255, BIT(PRINT_SCAN), },
-+#if 0
++#ifdef IW_FULL
        [1] = { "Supported rates", print_supprates, 0, 255, BIT(PRINT_SCAN), },
        [3] = { "DS Parameter set", print_ds, 1, 1, BIT(PRINT_SCAN), },
        [5] = { "TIM", print_tim, 4, 255, BIT(PRINT_SCAN), },
-@@ -1389,14 +1397,8 @@ static const struct ie_print ieprinters[
+@@ -1716,26 +1727,20 @@ static const struct ie_print ieprinters[
        [32] = { "Power constraint", print_powerconstraint, 1, 1, BIT(PRINT_SCAN), },
        [35] = { "TPC report", print_tpcreport, 2, 2, BIT(PRINT_SCAN), },
        [42] = { "ERP", print_erp, 1, 255, BIT(PRINT_SCAN), },
 -      [45] = { "HT capabilities", print_ht_capa, 26, 26, BIT(PRINT_SCAN), },
        [47] = { "ERP D4.0", print_erp, 1, 255, BIT(PRINT_SCAN), },
+       [51] = { "AP Channel Report", print_ap_channel_report, 1, 255, BIT(PRINT_SCAN), },
+       [59] = { "Supported operating classes", print_supp_op_classes, 1, 255, BIT(PRINT_SCAN), },
+       [66] = { "Measurement Pilot Transmission", print_measurement_pilot_tx, 1, 255, BIT(PRINT_SCAN), },
        [74] = { "Overlapping BSS scan params", print_obss_scan_params, 14, 255, BIT(PRINT_SCAN), },
 -      [61] = { "HT operation", print_ht_op, 22, 22, BIT(PRINT_SCAN), },
 -      [62] = { "Secondary Channel Offset", print_secchan_offs, 1, 1, BIT(PRINT_SCAN), },
 -      [192] = { "VHT operation", print_vht_oper, 5, 255, BIT(PRINT_SCAN), },
 -      [48] = { "RSN", print_rsn, 2, 255, BIT(PRINT_SCAN), },
        [50] = { "Extended supported rates", print_supprates, 0, 255, BIT(PRINT_SCAN), },
+       [70] = { "RM enabled capabilities", print_rm_enabled_capabilities, 5, 5, BIT(PRINT_SCAN), },
        [113] = { "MESH Configuration", print_mesh_conf, 7, 7, BIT(PRINT_SCAN), },
-       [114] = { "MESH ID", print_ssid, 0, 32, BIT(PRINT_SCAN) | BIT(PRINT_LINK), },
-@@ -1404,6 +1406,7 @@ static const struct ie_print ieprinters[
+-      [114] = { "MESH ID", print_ssid, 0, 32, BIT(PRINT_SCAN) | BIT(PRINT_LINK), },
+       [127] = { "Extended capabilities", print_capabilities, 0, 255, BIT(PRINT_SCAN), },
        [107] = { "802.11u Interworking", print_interworking, 0, 255, BIT(PRINT_SCAN), },
        [108] = { "802.11u Advertisement", print_11u_advert, 0, 255, BIT(PRINT_SCAN), },
-       [111] = { "802.11u Roaming Consortium", print_11u_rcon, 0, 255, BIT(PRINT_SCAN), },
+       [111] = { "802.11u Roaming Consortium", print_11u_rcon, 2, 255, BIT(PRINT_SCAN), },
+       [195] = { "Transmit Power Envelope", print_tx_power_envelope, 2, 5, BIT(PRINT_SCAN), },
 +#endif
  };
  
- static void print_wifi_wpa(const uint8_t type, uint8_t len, const uint8_t *data)
-@@ -1835,6 +1838,7 @@ void print_ies(unsigned char *ie, int ie
-                   ieprinters[ie[0]].name &&
+ static void print_wifi_wpa(const uint8_t type, uint8_t len, const uint8_t *data,
+@@ -2279,6 +2284,7 @@ void print_ies(unsigned char *ie, int ie
                    ieprinters[ie[0]].flags & BIT(ptype)) {
-                       print_ie(&ieprinters[ie[0]], ie[0], ie[1], ie + 2);
-+#if 0
+                       print_ie(&ieprinters[ie[0]],
+                                ie[0], ie[1], ie + 2, &ie_buffer);
++#ifdef IW_FULL
                } else if (ie[0] == 221 /* vendor */) {
                        print_vendor(ie[1], ie + 2, unknown, ptype);
                } else if (unknown) {
-@@ -1844,6 +1848,7 @@ void print_ies(unsigned char *ie, int ie
+@@ -2288,6 +2294,7 @@ void print_ies(unsigned char *ie, int ie
                        for (i=0; i<ie[1]; i++)
                                printf(" %.2x", ie[2+i]);
                        printf("\n");
                }
                ielen -= ie[1] + 2;
                ie += ie[1] + 2;
-@@ -1884,6 +1889,7 @@ static void print_capa_non_dmg(__u16 cap
+@@ -2328,6 +2335,7 @@ static void print_capa_non_dmg(__u16 cap
                printf(" ESS");
        if (capa & WLAN_CAPABILITY_IBSS)
                printf(" IBSS");
-+#if 0
++#ifdef IW_FULL
        if (capa & WLAN_CAPABILITY_CF_POLLABLE)
                printf(" CfPollable");
        if (capa & WLAN_CAPABILITY_CF_POLL_REQUEST)
-@@ -1912,6 +1918,7 @@ static void print_capa_non_dmg(__u16 cap
+@@ -2356,6 +2364,7 @@ static void print_capa_non_dmg(__u16 cap
                printf(" DelayedBACK");
        if (capa & WLAN_CAPABILITY_IMM_BACK)
                printf(" ImmediateBACK");
  }
  
  static int print_bss_handler(struct nl_msg *msg, void *arg)
-@@ -1996,8 +2003,10 @@ static int print_bss_handler(struct nl_m
+@@ -2440,8 +2449,10 @@ static int print_bss_handler(struct nl_m
        if (bss[NL80211_BSS_FREQUENCY]) {
                int freq = nla_get_u32(bss[NL80211_BSS_FREQUENCY]);
                printf("\tfreq: %d\n", freq);
-+#if 0
++#ifdef IW_FULL
                if (freq > 45000)
                        is_dmg = true;
 +#endif
        }
        if (bss[NL80211_BSS_BEACON_INTERVAL])
                printf("\tbeacon interval: %d TUs\n",
+@@ -2635,6 +2646,7 @@ static int handle_stop_sched_scan(struct
+       return 0;
+ }
++#ifdef IW_FULL
+ COMMAND(scan, sched_start,
+       SCHED_SCAN_OPTIONS,
+       NL80211_CMD_START_SCHED_SCAN, 0, CIB_NETDEV, handle_start_sched_scan,
+@@ -2645,3 +2657,4 @@ COMMAND(scan, sched_start,
+ COMMAND(scan, sched_stop, "",
+       NL80211_CMD_STOP_SCHED_SCAN, 0, CIB_NETDEV, handle_stop_sched_scan,
+       "Stop an ongoing scheduled scan.");
++#endif
 --- a/util.c
 +++ b/util.c
-@@ -268,6 +268,7 @@ static const char *commands[NL80211_CMD_
+@@ -153,6 +153,7 @@ static const char *commands[NL80211_CMD_
  
  static char cmdbuf[100];
  
-+#if 0
++#ifdef IW_FULL
  const char *command_name(enum nl80211_commands cmd)
  {
        if (cmd <= NL80211_CMD_MAX && commands[cmd])
-@@ -275,6 +276,7 @@ const char *command_name(enum nl80211_co
+@@ -160,6 +161,7 @@ const char *command_name(enum nl80211_co
        sprintf(cmdbuf, "Unknown command (%d)", cmd);
        return cmdbuf;
  }
  
  int ieee80211_channel_to_frequency(int chan, enum nl80211_band band)
  {
+@@ -311,6 +313,9 @@ int parse_keys(struct nl_msg *msg, char
+       char keybuf[13];
+       int pos = 0;
++#ifndef IW_FULL
++      return 1;
++#endif
+       if (!*argc)
+               return 1;
+--- a/Makefile
++++ b/Makefile
+@@ -23,6 +23,12 @@ _OBJS := $(sort $(patsubst %.c,%.o,$(wil
+ VERSION_OBJS := $(filter-out version.o, $(_OBJS))
+ OBJS := $(VERSION_OBJS) version.o
++OBJS_FULL = ocb offch cqm wowlan coalesce roc p2p vendor mgmt ap sha256 nan bloom measurements ftm
++ifdef IW_FULL
++  CFLAGS += -DIW_FULL
++else
++  OBJS:=$(filter-out $(patsubst %,%.o,$(OBJS_FULL)),$(OBJS))
++endif
+ ALL = iw
+ ifeq ($(NO_PKG_CONFIG),)
+--- a/station.c
++++ b/station.c
+@@ -777,10 +777,12 @@ static int handle_station_set_plink(stru
+  nla_put_failure:
+       return -ENOBUFS;
+ }
++#ifdef IW_FULL
+ COMMAND_ALIAS(station, set, "<MAC address> plink_action <open|block>",
+       NL80211_CMD_SET_STATION, 0, CIB_NETDEV, handle_station_set_plink,
+       "Set mesh peer link action for this station (peer).",
+       select_station_cmd, station_set_plink);
++#endif
+ static int handle_station_set_vlan(struct nl80211_state *state,
+                                  struct nl_msg *msg,
+@@ -875,11 +877,13 @@ static int handle_station_set_mesh_power
+ nla_put_failure:
+       return -ENOBUFS;
+ }
++#ifdef IW_FULL
+ COMMAND_ALIAS(station, set, "<MAC address> mesh_power_mode "
+       "<active|light|deep>", NL80211_CMD_SET_STATION, 0, CIB_NETDEV,
+       handle_station_set_mesh_power_mode,
+       "Set link-specific mesh power mode for this station",
+       select_station_cmd, station_set_mesh_power_mode);
++#endif
+ static int handle_station_set_airtime_weight(struct nl80211_state *state,
+                                            struct nl_msg *msg,
+--- a/interface.c
++++ b/interface.c
+@@ -627,9 +627,11 @@ static int handle_interface_wds_peer(str
+  nla_put_failure:
+       return -ENOBUFS;
+ }
++#ifdef IW_FULL
+ COMMAND(set, peer, "<MAC address>",
+       NL80211_CMD_SET_WDS_PEER, 0, CIB_NETDEV, handle_interface_wds_peer,
+       "Set interface WDS peer.");
++#endif
+ static int set_mcast_rate(struct nl80211_state *state,
+                         struct nl_msg *msg,
+@@ -719,6 +721,7 @@ static int handle_chan(struct nl80211_st
+       return handle_chanfreq(state, msg, true, argc, argv, id);
+ }
++#ifdef IW_FULL
+ SECTION(switch);
+ COMMAND(switch, freq,
+       "<freq> [NOHT|HT20|HT40+|HT40-|5MHz|10MHz|80MHz] [beacons <count>] [block-tx]\n"
+@@ -956,3 +959,4 @@ COMMAND(set, tidconf, "[peer <MAC addres
+       "  $ iw dev wlan0 tids 0x3 override ampdu on noack on rtscts on\n"
+       "  $ iw dev wlan0 peer xx:xx:xx:xx:xx:xx tids 0x1 ampdu off tids 0x3 amsdu off rtscts on\n"
+       );
++#endif
+--- a/phy.c
++++ b/phy.c
+@@ -369,6 +369,7 @@ err_out:
+               free(cac_trigger_argv);
+       return err;
+ }
++#ifdef IW_FULL
+ TOPLEVEL(cac, "channel <channel> [NOHT|HT20|HT40+|HT40-|5MHz|10MHz|80MHz]\n"
+             "freq <freq> [NOHT|HT20|HT40+|HT40-|5MHz|10MHz|80MHz]\n"
+             "freq <control freq> [5|10|20|40|80|80+80|160] [<center1_freq> [<center2_freq>]]",
+@@ -380,6 +381,7 @@ COMMAND(cac, trigger,
+       NL80211_CMD_RADAR_DETECT, 0, CIB_NETDEV, handle_cac_trigger,
+       "Start or trigger a channel availability check (CAC) looking to look for\n"
+       "radars on the given channel.");
++#endif
+ static int handle_fragmentation(struct nl80211_state *state,
+                               struct nl_msg *msg,