iwinfo: adjust for changed wpa_supplicant control socket path
[openwrt/svn-archive/archive.git] / package / network / utils / iwinfo / Makefile
index 23f3f38cb4d5d7a9ee73bab8d8f55aca77c8f6d2..699682b95e97df36a597ed5a2b348a1261a4e0ce 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2013 Jo-Philipp Wich <xm@subsignal.org>
+# Copyright (C) 2010-2014 Jo-Philipp Wich <xm@subsignal.org>
 #
 # This is free software, licensed under the GPL 2 license.
 #
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiwinfo
-PKG_RELEASE:=40
+PKG_RELEASE:=48
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
@@ -101,6 +101,8 @@ endef
 define Package/libiwinfo/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/libiwinfo.so $(1)/usr/lib/libiwinfo.so
+       $(INSTALL_DIR) $(1)/usr/share/libiwinfo
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/hardware.txt $(1)/usr/share/libiwinfo/hardware.txt
 endef
 
 define Package/libiwinfo-lua/install