remove linux-atm from ppp build deps - the internal version seems to be working
[openwrt/staging/yousong.git] / package / ppp / Makefile
index dc1f37b0a95623544d31af82e63d61278af333b8..ee58f72e479d129dd772eaa6ca973189ee943be1 100644 (file)
@@ -10,17 +10,13 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.3
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
 PKG_MD5SUM:=848f6c3cafeb6074ffeb293c3af79b7c
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-PKG_BUILDDEP:=libpcap linux-atm
+PKG_BUILD_DEPENDS:=libpcap
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -32,64 +28,79 @@ define Package/ppp/Default
 endef
 
 define Package/ppp
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=+kmod-ppp
   TITLE:=PPP daemon
-  DESCRIPTION:=\
-       This package contains the PPP (Point-to-Point Protocol) daemon.
   MENU:=1
 endef
 
+define Package/ppp/description
+ This package contains the PPP (Point-to-Point Protocol) daemon.
+endef
+
 define Package/ppp-mod-pppoa
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp +linux-atm +kmod-pppoa
   TITLE:=PPPoA plugin
-  DESCRIPTION:=\
-       This package contains a PPPoA (PPP over ATM) plugin for ppp.
+endef
+
+define Package/ppp-mod-pppoa/description
+ This package contains a PPPoA (PPP over ATM) plugin for ppp.
 endef
 
 define Package/ppp-mod-pppoe
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp +kmod-pppoe
   TITLE:=PPPoE plugin
-  DESCRIPTION:=\
-       This package contains a PPPoE (PPP over Ethernet) plugin for ppp.
+endef
+
+define Package/ppp-mod-pppoe/description
+ This package contains a PPPoE (PPP over Ethernet) plugin for ppp.
 endef
 
 define Package/ppp-mod-radius
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp
   TITLE:=RADIUS plugin
-  DESCRIPTION:=\
-       This package contains a RADIUS (Remote Authentication Dial-In User \\\
-       Service) plugin for ppp.
+endef
+
+define Package/ppp-mod-radius/description
+ This package contains a RADIUS (Remote Authentication Dial-In User 
+ Service) plugin for ppp.
 endef
 
 define Package/chat
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp
   TITLE:=Establish conversation with a modem
-  DESCRIPTION:=\
-       This package contains an utility to establish conversation with other \\\
-       PPP servers (via a modem).
+endef
+
+define Package/chat/description
+ This package contains an utility to establish conversation with other 
+ PPP servers (via a modem).
 endef
 
 define Package/pppdump
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp
   TITLE:=Read PPP record file
-  DESCRIPTION:=\
-       This package contains an utility to read PPP record file.
+endef
+
+define Package/pppdump/description
+ This package contains an utility to read PPP record file.
 endef
 
 define Package/pppstats
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp
   TITLE:=Report PPP statistics
-  DESCRIPTION:=\
-       This package contains an utility to report PPP statistics.
 endef
 
+define Package/pppstats/description
+ This package contains an utility to report PPP statistics.
+endef
+
+
 define Build/Configure
 $(call Build/Configure/Default,, \
        UNAME_S="Linux" \