fix a race condition where ppp interfaces were not added to the firewall properly...
[openwrt/staging/florian.git] / package / ppp / patches / 203-no_strip.patch
index 216973cf599d160e564e3b6711812a15c6623109..f3df1fc9fd055c454589ad57937167935ed73860 100644 (file)
@@ -1,6 +1,7 @@
-diff -ruN ppp-2.4.3-orig/chat/Makefile.linux ppp-2.4.3-3/chat/Makefile.linux
---- ppp-2.4.3-orig/chat/Makefile.linux 2004-11-03 12:51:47.000000000 +0100
-+++ ppp-2.4.3-3/chat/Makefile.linux    2004-12-05 17:42:43.000000000 +0100
+Index: ppp-2.4.3/chat/Makefile.linux
+===================================================================
+--- ppp-2.4.3.orig/chat/Makefile.linux 2007-06-04 13:22:08.064629272 +0200
++++ ppp-2.4.3/chat/Makefile.linux      2007-06-04 13:22:12.463960472 +0200
 @@ -25,7 +25,7 @@
  
  install: chat
@@ -10,9 +11,10 @@ diff -ruN ppp-2.4.3-orig/chat/Makefile.linux ppp-2.4.3-3/chat/Makefile.linux
        $(INSTALL) -c -m 644 chat.8 $(MANDIR)
  
  clean:
-diff -ruN ppp-2.4.3-orig/pppd/Makefile.linux ppp-2.4.3-3/pppd/Makefile.linux
---- ppp-2.4.3-orig/pppd/Makefile.linux 2004-11-13 13:02:22.000000000 +0100
-+++ ppp-2.4.3-3/pppd/Makefile.linux    2004-12-16 04:43:41.000000000 +0100
+Index: ppp-2.4.3/pppd/Makefile.linux
+===================================================================
+--- ppp-2.4.3.orig/pppd/Makefile.linux 2007-06-04 13:22:11.837055776 +0200
++++ ppp-2.4.3/pppd/Makefile.linux      2007-06-04 13:22:12.463960472 +0200
 @@ -99,7 +99,7 @@
  CFLAGS        += -DUSE_SRP -DOPENSSL -I/usr/local/ssl/include
  LIBS  += -lsrp -L/usr/local/ssl/lib -lcrypto
@@ -31,10 +33,11 @@ diff -ruN ppp-2.4.3-orig/pppd/Makefile.linux ppp-2.4.3-3/pppd/Makefile.linux
        if chgrp pppusers $(BINDIR)/pppd 2>/dev/null; then \
          chmod o-rx,u+s $(BINDIR)/pppd; fi
        $(INSTALL) -c -m 444 pppd.8 $(MANDIR)
-diff -ruN ppp-2.4.3-orig/pppd/plugins/radius/Makefile.linux ppp-2.4.3-3/pppd/plugins/radius/Makefile.linux
---- ppp-2.4.3-orig/pppd/plugins/radius/Makefile.linux  2004-11-14 08:02:31.000000000 +0100
-+++ ppp-2.4.3-3/pppd/plugins/radius/Makefile.linux     2004-12-05 17:43:17.000000000 +0100
-@@ -36,9 +37,9 @@
+Index: ppp-2.4.3/pppd/plugins/radius/Makefile.linux
+===================================================================
+--- ppp-2.4.3.orig/pppd/plugins/radius/Makefile.linux  2007-06-04 13:22:08.076627448 +0200
++++ ppp-2.4.3/pppd/plugins/radius/Makefile.linux       2007-06-04 13:22:12.463960472 +0200
+@@ -36,9 +36,9 @@
  
  install: all
        $(INSTALL) -d -m 755 $(LIBDIR)
@@ -47,9 +50,10 @@ diff -ruN ppp-2.4.3-orig/pppd/plugins/radius/Makefile.linux ppp-2.4.3-3/pppd/plu
        $(INSTALL) -c -m 444 pppd-radius.8 $(MANDIR)
        $(INSTALL) -c -m 444 pppd-radattr.8 $(MANDIR)
  
-diff -ruN ppp-2.4.3-orig/pppd/plugins/rp-pppoe/Makefile.linux ppp-2.4.3-3/pppd/plugins/rp-pppoe/Makefile.linux
---- ppp-2.4.3-orig/pppd/plugins/rp-pppoe/Makefile.linux        2004-11-14 08:58:37.000000000 +0100
-+++ ppp-2.4.3-3/pppd/plugins/rp-pppoe/Makefile.linux   2004-12-05 17:43:23.000000000 +0100
+Index: ppp-2.4.3/pppd/plugins/rp-pppoe/Makefile.linux
+===================================================================
+--- ppp-2.4.3.orig/pppd/plugins/rp-pppoe/Makefile.linux        2007-06-04 13:22:09.416423768 +0200
++++ ppp-2.4.3/pppd/plugins/rp-pppoe/Makefile.linux     2007-06-04 13:22:12.468959712 +0200
 @@ -39,9 +39,9 @@
  
  install: all
@@ -62,19 +66,21 @@ diff -ruN ppp-2.4.3-orig/pppd/plugins/rp-pppoe/Makefile.linux ppp-2.4.3-3/pppd/p
  
  clean:
        rm -f *.o *.so
-diff -ruN ppp-2.4.3-orig/pppdump/Makefile.linux ppp-2.4.3-3/pppdump/Makefile.linux
---- ppp-2.4.3-orig/pppdump/Makefile.linux      2004-10-31 02:36:52.000000000 +0200
-+++ ppp-2.4.3-3/pppdump/Makefile.linux 2004-12-05 17:50:34.000000000 +0100
-@@ -17,5 +18,5 @@
+Index: ppp-2.4.3/pppdump/Makefile.linux
+===================================================================
+--- ppp-2.4.3.orig/pppdump/Makefile.linux      2007-06-04 13:22:08.091625168 +0200
++++ ppp-2.4.3/pppdump/Makefile.linux   2007-06-04 13:22:12.468959712 +0200
+@@ -17,5 +17,5 @@
  
  install:
        mkdir -p $(BINDIR) $(MANDIR)
 -      $(INSTALL) -s -c pppdump $(BINDIR)
 +      $(INSTALL) -c pppdump $(BINDIR)
        $(INSTALL) -c -m 444 pppdump.8 $(MANDIR)
-diff -ruN ppp-2.4.3-orig/pppstats/Makefile.linux ppp-2.4.3-3/pppstats/Makefile.linux
---- ppp-2.4.3-orig/pppstats/Makefile.linux     2004-10-31 23:09:03.000000000 +0100
-+++ ppp-2.4.3-3/pppstats/Makefile.linux        2004-12-05 17:43:38.000000000 +0100
+Index: ppp-2.4.3/pppstats/Makefile.linux
+===================================================================
+--- ppp-2.4.3.orig/pppstats/Makefile.linux     2007-06-04 13:22:08.099623952 +0200
++++ ppp-2.4.3/pppstats/Makefile.linux  2007-06-04 13:22:12.468959712 +0200
 @@ -22,7 +22,7 @@
  
  install: pppstats