add jffs2_mark_erase function for erasing jffs2 partitions on the next mount (typical...
[openwrt/svn-archive/archive.git] / package / rt2500 / Makefile
index ca1b837be411a6d532e2ba171d7c57599bb236c3..fb6d59451627b1e20e5a5861385b5eb9864e157b 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 5314 2006-10-27 19:14:43Z nico $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -16,16 +16,13 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/rt2400
 PKG_MD5SUM:=83b8b9a091705c08d99268479f3b3b6a
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/rt2500
   SUBMENU:=Wireless Drivers
   TITLE:=Driver for ralink pci wireless chipsets
-  DEPENDS:=@USB_SUPPORT +wireless-tools
+  DEPENDS:=@LINUX_2_4 @USB_SUPPORT +wireless-tools
   DESCRIPTION:=\
        This package contains a driver for ralink rt2500 pci chipsets.
   URL:=http://rt2x00.serialmonkey.com/