opkg: drop argument from check_signature in opkg.conf
[openwrt/staging/chunkeey.git] / package / system / opkg / Makefile
index 22a1c93ef4cb6f954c67ee8ad8c55b5b7346637b..67105675e8d0d6b307db6f035b9a81cd5d68438f 100644 (file)
@@ -1,31 +1,32 @@
 #
 # Copyright (C) 2006-2015 OpenWrt.org
-# Copyright (C) 2016 LEDE Project
+# Copyright (C) 2016-2017 LEDE Project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
-include $(INCLUDE_DIR)/version.mk
-include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=opkg
-PKG_RELEASE:=1
+PKG_RELEASE:=3
+PKG_FLAGS:=essential
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://git.lede-project.org/project/opkg-lede.git
-PKG_SOURCE_DATE:=2017-02-22
-PKG_SOURCE_VERSION:=271d485c10f2070573b25e740b93839945dbcd9d
-PKG_MIRROR_HASH:=f48fcbc9f509629aec30bca6aeaf78d831c9a041ac87468f7429d20361384ca9
+PKG_SOURCE_URL:=https://git.openwrt.org/project/opkg-lede.git
+PKG_SOURCE_DATE:=2017-12-07
+PKG_SOURCE_VERSION:=3b417b9f41b4ceb5912d82f867dd5534e5675b5c
+PKG_MIRROR_HASH:=1c9c21e56186345d0034d15051c1d9c5ebb5aa6658d6ae8886d8403207a914a3
 
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=COPYING
 
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 
-PKG_FLAGS := nonshared
-PKG_CONFIG_DEPENDS := CONFIG_SIGNED_PACKAGES
+# Extend depends from version.mk
+PKG_CONFIG_DEPENDS += \
+       CONFIG_SIGNED_PACKAGES \
+       CONFIG_TARGET_INIT_PATH
 
 PKG_BUILD_PARALLEL:=1
 HOST_BUILD_PARALLEL:=1
@@ -42,7 +43,7 @@ define Package/opkg
   CATEGORY:=Base system
   TITLE:=opkg package manager
   DEPENDS:=+uclient-fetch +libpthread +libubox
-  URL:=https://git.lede-project.org/?p=project/opkg-lede.git
+  URL:=$(PKG_SOURCE_URL)
   MENU:=1
 endef
 
@@ -68,6 +69,7 @@ EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
 CMAKE_OPTIONS += \
        -DBUILD_TESTS=OFF \
        -DHOST_CPU=$(PKGARCH) \
+       -DPATH_SPEC="$(TARGET_INIT_PATH)" \
        -DVERSION="$(PKG_SOURCE_VERSION) ($(PKG_SOURCE_DATE))"
 
 CMAKE_HOST_OPTIONS += \
@@ -84,12 +86,10 @@ define Package/opkg/install
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_DATA) ./files/customfeeds.conf $(1)/etc/opkg/customfeeds.conf
        $(INSTALL_DATA) ./files/opkg$(2).conf $(1)/etc/opkg.conf
-       $(call FeedSourcesAppend,$(1)/etc/opkg/distfeeds.conf)
-       $(VERSION_SED) $(1)/etc/opkg/distfeeds.conf
        $(INSTALL_BIN) ./files/20_migrate-feeds $(1)/etc/uci-defaults/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
   ifneq ($(CONFIG_SIGNED_PACKAGES),)
-       echo "option check_signature 1" >> $(1)/etc/opkg.conf
+       echo "option check_signature" >> $(1)/etc/opkg.conf
   endif
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) ./files/opkg-key $(1)/usr/sbin/