hostapd: fix AP+STA reconnects
[openwrt/svn-archive/archive.git] / package / uboot-kirkwood / Makefile
index f3f9259a73ceb2a491c3d2e0306c9fd1e1d31fd7..cdf35a4caa15793de6fe4bcd05b26eed2f5d3748 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=u-boot
-PKG_VERSION:=2010.03
+PKG_VERSION:=2010.09
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -34,7 +34,11 @@ define uboot/dockstar
   TITLE:=U-boot for the Seagate Dockstar
 endef
 
-UBOOTS:=sheevaplug dockstar
+define uboot/iconnect
+  TITLE:=U-boot for the Iomega iConnect Wireless
+endef
+
+UBOOTS:=sheevaplug dockstar iconnect
 
 define Package/uboot/template
 define Package/uboot-kirkwood-$(1)
@@ -57,7 +61,7 @@ endef
 ifdef BUILD_VARIANT
 $(eval $(call uboot/$(BUILD_VARIANT)))
 UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
-UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_BARIANT)-u-boot.bin)
+UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
 endif
 
 define Build/Prepare
@@ -73,6 +77,7 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               u-boot.kwb \
                CROSS_COMPILE=$(TARGET_CROSS)
 endef
 
@@ -80,6 +85,8 @@ define Package/uboot/install/default
        $(INSTALL_DIR) $(BIN_DIR)
        $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
                $(BIN_DIR)/openwrt-$(BOARD)-$(1)-u-boot.bin
+       $(CP) $(PKG_BUILD_DIR)/u-boot.kwb \
+               $(BIN_DIR)/openwrt-$(BOARD)-$(1)-u-boot.kwb
 endef
 
 define Package/uboot/install/template