upgrade uci to 0.3.0 - fix for adding changes to empty config files - better error...
[openwrt/staging/florian.git] / package / uci / Makefile
index 616f46fa46244f3950444ebc14bf313530c4e871..54d01c15894676e002d7031debaa989492907cf5 100644 (file)
@@ -8,13 +8,17 @@
 
 include $(TOPDIR)/rules.mk
 
+UCI_VERSION=0.3
+UCI_RELEASE=0
+
 PKG_NAME:=uci
-PKG_VERSION:=0.1
+PKG_VERSION:=$(UCI_VERSION)$(if $(UCI_RELEASE),.$(UCI_RELEASE))
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=f6340dce09f5f1552c4e03be98e64265
+PKG_MD5SUM:=ed870a7e7765e93e3bbfa98b4eb5b803
+
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -49,7 +53,7 @@ define Build/Compile
                $(TARGET_CONFIGURE_OPTS) \
                COPTS="$(TARGET_CFLAGS)" \
                DEBUG="$(DEBUG)" \
-               VERSION="$(PKG_VERSION)" \
+               VERSION="$(UCI_VERSION)" \
                OS="Linux"
 endef