packages: nvram: add NVRAM quirks for bcm53xx target
[openwrt/staging/chunkeey.git] / package / utils / nvram / Makefile
index ab479e36b2dded94c1f7401bd04c399912f82221..b957211283d12b8085c7768ec2e7272b7fdc17b5 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nvram
-PKG_RELEASE:=10
+PKG_RELEASE:=11
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
@@ -21,7 +21,7 @@ define Package/nvram
   CATEGORY:=Base system
   TITLE:=Userspace port of the Broadcom NVRAM manipulation tool
   MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
-  DEPENDS:=@(TARGET_brcm47xx||TARGET_bcm53xx||TARGET_ar71xx||TARGET_ath79)
+  DEPENDS:=@(TARGET_bcm47xx||TARGET_bcm53xx||TARGET_ath79)
 endef
 
 define Package/nvram/description
@@ -42,9 +42,13 @@ endef
 define Package/nvram/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/nvram $(1)/usr/sbin/
-ifneq ($(CONFIG_TARGET_brcm47xx),)
+ifneq ($(CONFIG_TARGET_bcm47xx),)
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/nvram.init $(1)/etc/init.d/nvram
+       $(INSTALL_BIN) ./files/nvram-bcm47xx.init $(1)/etc/init.d/nvram
+endif
+ifneq ($(CONFIG_TARGET_bcm53xx),)
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/nvram-bcm53xx.init $(1)/etc/init.d/nvram
 endif
 endef