add optional driver for the hw watchdog on gateworks avila boards (requires soldering...
[openwrt/svn-archive/archive.git] / package / wireless-tools / Makefile
index ff16c065c622fb2aba628712c847bf66aec911f0..34b6a20370563e2d878c3cea02ed6427d68a79ec 100644 (file)
@@ -1,32 +1,35 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wireless-tools
 PKG_VERSION:=29
-PKG_MINOR:=.pre21
-PKG_RELEASE:=2
+PKG_MINOR:=
+PKG_RELEASE:=3
 
 PKG_SOURCE:=wireless_tools.$(PKG_VERSION)$(PKG_MINOR).tar.gz
 PKG_SOURCE_URL:=http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux
-PKG_MD5SUM:=953774d6a34050bae4ef3bfa731f6653
+PKG_MD5SUM:=e06c222e186f7cc013fd272d023710cb
 TAR_OPTIONS += || true
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/wireless_tools.$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
+define Package/wireless-tools/Default
+  URL:=http://hplabs.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html
+endef
+
 define Package/wireless-tools
+$(call Package/wireless-tools/Default)
   SECTION:=net
   CATEGORY:=Base system
   TITLE:=Tools for manipulating Linux Wireless Extensions
-  URL:=http://hplabs.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html
 endef
 
 define Package/wireless-tools/description
@@ -34,6 +37,18 @@ define Package/wireless-tools/description
  adapters implementing the "Linux Wireless Extensions".
 endef
 
+define Package/libiw
+$(call Package/wireless-tools/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Library for manipulating Linux Wireless Extensions
+endef
+
+define Package/libiw/description
+ This package contains a library for manipulating
+ "Linux Wireless Extensions".
+endef
+
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
@@ -65,4 +80,10 @@ define Package/wireless-tools/install
        ln -sf iwconfig $(1)/usr/sbin/iwspy
 endef
 
+define Package/libiw/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libiw.so.* $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,wireless-tools))
+$(eval $(call BuildPackage,libiw))