package/mtd: write remaining data after adding file to the jffs2 partition
[openwrt/staging/yousong.git] / package / wrt55agv2-spidevs / Makefile
index fa9b1c07ab6378befa710e05468368ea31179daa..a149303888a22525dbb77bb9f2ae31739f92c266 100644 (file)
@@ -16,8 +16,8 @@ include $(INCLUDE_DIR)/package.mk
 define KernelPackage/wrt55agv2-spidevs
   SUBMENU:=Other modules
   TITLE:=WRT55AG v2 SPI devices support
-  DEPENDS:=@LINUX_2_6 @TARGET_atheros +kmod-spi-gpio +kmod-spi-ks8995
-  FILES:=$(PKG_BUILD_DIR)/wrt55agv2_spidevs.$(LINUX_KMOD_SUFFIX)
+  DEPENDS:=@TARGET_atheros +kmod-spi-gpio-old +kmod-spi-ks8995
+  FILES:=$(PKG_BUILD_DIR)/wrt55agv2_spidevs.ko
 endef
 
 define KernelPackage/wrt55agv2-spidevs/description
@@ -36,7 +36,7 @@ MAKE_OPTS:= \
        CROSS_COMPILE="$(TARGET_CROSS)" \
        SUBDIRS="$(PKG_BUILD_DIR)" \
        EXTRA_CFLAGS="$(EXTRA_CFLAGS)" \
-       LINUXINCLUDE="-I$(LINUX_DIR)/include -include linux/autoconf.h" \
+       LINUXINCLUDE="-I$(LINUX_DIR)/include -I$(LINUX_DIR)/arch/mips/include -include linux/autoconf.h" \
        $(EXTRA_KCONFIG)
 
 define Build/Prepare