Refactor ARMv8.3 Pointer Authentication support code
[project/bcm63xx/atf.git] / plat / arm / common / arm_common.mk
index 10b6e512269dd5b5e853a8245ad4ecc9871d9043..a4a29bf74a713aff92a9ed8f4bc9db3445f93fcc 100644 (file)
@@ -234,7 +234,8 @@ endif
 
 # Pointer Authentication sources
 ifeq (${ENABLE_PAUTH}, 1)
-PLAT_BL_COMMON_SOURCES +=      plat/arm/common/aarch64/arm_pauth.c
+PLAT_BL_COMMON_SOURCES +=      plat/arm/common/aarch64/arm_pauth.c     \
+                               lib/extensions/pauth/pauth_helpers.S
 endif
 
 # SPM uses libfdt in Arm platforms