Merge pull request #1277 from hzhuang1/testing/bl2_el3_v0.6
[project/bcm63xx/atf.git] / plat / hisilicon / hikey / platform.mk
index 81bf1f52447bea2b27e3944c0c1b48eb208c9ec6..38eb148cf5b51ffc11e353baa35b75d399a1c4fa 100644 (file)
@@ -12,11 +12,11 @@ BL2_AT_EL3  :=      1
 
 # On Hikey, the TSP can execute from TZC secure area in DRAM (default)
 # or SRAM.
-HIKEY_TSP_RAM_LOCATION :=      dram
+HIKEY_TSP_RAM_LOCATION ?=      dram
 ifeq (${HIKEY_TSP_RAM_LOCATION}, dram)
   HIKEY_TSP_RAM_LOCATION_ID = HIKEY_DRAM_ID
 else ifeq (${HIKEY_TSP_RAM_LOCATION}, sram)
-  HIKEY_TSP_RAM_LOCATION_ID := HIKEY_SRAM_ID
+  HIKEY_TSP_RAM_LOCATION_ID = HIKEY_SRAM_ID
 else
   $(error "Currently unsupported HIKEY_TSP_RAM_LOCATION value")
 endif
@@ -39,10 +39,10 @@ $(eval $(call add_define,PLAT_PARTITION_MAX_ENTRIES))
 # Add the build options to pack Trusted OS Extra1 and Trusted OS Extra2 images
 # in the FIP if the platform requires.
 ifneq ($(BL32_EXTRA1),)
-$(eval $(call FIP_ADD_IMG,BL32_EXTRA1,--tos-fw-extra1))
+$(eval $(call TOOL_ADD_IMG,bl32_extra1,--tos-fw-extra1))
 endif
 ifneq ($(BL32_EXTRA2),)
-$(eval $(call FIP_ADD_IMG,BL32_EXTRA2,--tos-fw-extra2))
+$(eval $(call TOOL_ADD_IMG,bl32_extra2,--tos-fw-extra2))
 endif
 
 ENABLE_PLAT_COMPAT     :=      0
@@ -127,4 +127,6 @@ ERRATA_A53_836870           :=      1
 ERRATA_A53_843419              :=      1
 ERRATA_A53_855873              :=      1
 
+WORKAROUND_CVE_2017_5715       :=      0
+
 FIP_ALIGN                      :=      512