fix up dependencies
[openwrt/staging/wigyori.git] / rules.mk
index e363517b1cc2cfabea109c0bef31ab020480138a..9ec98961ce376c8eabe4b38776464e1b26a26ba2 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -83,7 +83,8 @@ TARGET_CONFIGURE_OPTS:= \
   CXX=$(TARGET_CROSS)g++ \
   RANLIB=$(TARGET_CROSS)ranlib \
   STRIP=$(TARGET_CROSS)strip \
-  OBJCOPY=$(TARGET_CROSS)objcopy
+  OBJCOPY=$(TARGET_CROSS)objcopy \
+       OBJDUMP=$(TARGET_CROSS)objdump
 
 # strip an entire directory
 RSTRIP:= \
@@ -143,7 +144,7 @@ define default_subtargets
   %-compile: %-prepare 
        $$(MAKE) -C $$(patsubst %-compile,%,$$@) compile
 
-  %-install: %-compile
+  %-install: 
        $$(MAKE) -C $$(patsubst %-install,%,$$@) install
 
   %-clean: FORCE