scripts: ext-toolchain: add support for info.mk in probe_cc
[openwrt/staging/svanheule.git] / scripts / ext-toolchain.sh
index 1ef3f42c50a9e4121c54c0bdb0c0ae7b5b3020fe..1f8eca30769a81cf599c439c8466220752f44801 100755 (executable)
@@ -463,6 +463,13 @@ probe_cpp() {
 }
 
 probe_libc() {
+       if [ -f $TOOLCHAIN/info.mk ]; then
+               LIBC_TYPE=$(grep LIBC_TYPE $TOOLCHAIN/info.mk | sed 's/LIBC_TYPE=//')
+               return 0
+       fi
+
+       echo "Warning! Can't find info.mk, trying to detect with alternative way."
+
        if [ -z "$LIBC_TYPE" ]; then
                if test_uclibc; then
                        LIBC_TYPE="uclibc"