forked-daapd: Fix build error due to misdetected pulseaudio
[feed/packages.git] / sound / forked-daapd / Makefile
index 7f2c7225dfcbdba51e932b62aa86ffa955acd27b..da371a717e0d93af9224b1260893648e52d13ac1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=forked-daapd
-PKG_VERSION:=24.1
+PKG_VERSION:=25.0
 PKG_RELEASE:=1
-PKG_REV:=524d060b7a9a68ab4375460d2da611a80e4fc18b
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://github.com/ejurgensen/forked-daapd.git
-PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://github.com/ejurgensen/$(PKG_NAME)/releases/download/$(PKG_VERSION)/
+PKG_HASH:=5741a64d8f54e11e89dfa2fbfae693b2837e1e19a0c4980a20f8ff56bce4456e
 
 PKG_BUILD_DEPENDS:=gperf/host
 PKG_FIXUP:=autoreconf
@@ -38,7 +35,7 @@ URL:=https://github.com/ejurgensen/forked-daapd
 DEPENDS:=+libgpg-error +libgcrypt +libgdbm +zlib +libexpat +libunistring \
        +libevent2 +libdaemon +libantlr3c +confuse +alsa-lib +libffmpeg-full \
        +mxml +libavahi-client +sqlite3-cli +libplist +libcurl +libjson-c \
-       +libprotobuf-c +libgnutls $(ICONV_DEPENDS)
+       +libprotobuf-c +libgnutls +libsodium $(ICONV_DEPENDS)
 endef
 
 define Package/forked-daapd/description
@@ -56,7 +53,11 @@ CONFIGURE_ARGS += \
        --enable-itunes \
        --enable-lastfm \
        --enable-mpd \
-       --enable-chromecast
+       --enable-chromecast \
+       --enable-verification \
+       --disable-spotify \
+       --without-pulseaudio \
+       --without-libevent_pthreads
 
 TARGET_CFLAGS += $(FPIC)
 TARGET_LDFLAGS += -Wl,-rpath-link,$(STAGING_DIR)/usr/lib