[packages] transmission: update to 2.61
[openwrt/svn-archive/archive.git] / sound / mpc / Makefile
index 2fd1b243fa3c937fac80fa98b4d132a52044e0cc..4bf73084762c80492b1e1e27ddc432638c2423ae 100644 (file)
@@ -1,33 +1,33 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpc
-PKG_VERSION:=0.12.1
-PKG_RELEASE:=2
+PKG_VERSION:=0.20
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.musicpd.org/uploads/files/
-PKG_MD5SUM:=a93a390315aacfec061c8df89fb5e35f
+PKG_SOURCE_URL:=@SF/musicpd
+PKG_MD5SUM:=24c81ad6afe6099e8d7a6826ef4b7105
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/mpc
   SECTION:=sound
   CATEGORY:=Sound
+  DEPENDS:=+libmpdclient
   TITLE:=Music Player Daemon Console Client
   URL:=http://www.musicpd.org/
 endef
 
 define Package/mpc/description
        MPD is a music player supporting flac, mp3 and ogg files.
-       It is typically controlled over a network using one of it's many 
+       It is typically controlled over a network using one of it's many
        clients including mpc(console), gmpc(gnome), phpmp(php) etc.
        this is MPC
 endef
@@ -40,6 +40,7 @@ endef
 
 define Build/Compile
 $(call Build/Compile/Default,\
+               CFLAGS="$(TARGET_CFLAGS) -std=gnu99" \
                prefix="/usr" \
                all \
 )
@@ -47,8 +48,8 @@ endef
 
 define Package/mpc/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/mpc $(1)/usr/bin/
-       $(INSTALL_BIN) ./files/pls-handler.sh $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mpc $(1)/usr/bin/
+       $(INSTALL_BIN) ./files/pls-handler.sh $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,mpc))