strongswan: add missing patch for avoiding collisions with uclibc functions
[openwrt/svn-archive/archive.git] / sound / pulseaudio / Makefile
index bcbcf28b0a7bb4e135ee61079718be425fde7c4f..24ac2db506ffb34fd36826e16b26b01a283196ee 100644 (file)
@@ -8,17 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pulseaudio
-PKG_VERSION:=4.0
+PKG_VERSION:=5.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://freedesktop.org/software/pulseaudio/releases/
-PKG_MD5SUM:=591f211db2790a7e4d222f2dc6858db3
+PKG_MD5SUM:=c43749838612f4860465e83ed62ca38e
 
 PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_BUILD_DEPENDS:=intltool/host
 
 PKG_FIXUP:=autoreconf
+PKG_USE_MIPS16:=0
 
 PKG_INSTALL = 1
 
@@ -30,7 +31,7 @@ define Package/pulseaudio/Default
   SECTION:=sound
   CATEGORY:=Sound
   DEPENDS:=+libspeexdsp +libsndfile +libltdl +libpthread \
-       +librt +alsa-lib +libjson +libopenssl +libwrap $(ICONV_DEPENDS) $(INTL_DEPENDS)
+       +librt +alsa-lib +libjson +libopenssl +libwrap +libcap $(ICONV_DEPENDS) $(INTL_DEPENDS)
   TITLE:=Network sound server
   MAINTAINER:=Peter Wagner <tripolar@gmx.at>
   URL:=http://www.pulseaudio.org
@@ -115,7 +116,6 @@ CONFIGURE_ARGS += \
        --disable-lirc \
        --disable-bluez \
        --disable-udev \
-       --without-caps \
        --without-fftw
 
 ifeq ($(BUILD_VARIANT),avahi)
@@ -163,7 +163,7 @@ define Package/pulseaudio-daemon/install
                $(1)/usr/bin \
                $(1)/usr/lib \
                $(1)/usr/lib/pulseaudio \
-               $(1)/usr/lib/pulse-$(PKG_VERSION)/modules 
+               $(1)/usr/lib/pulse-$(PKG_VERSION)/modules
 
        $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/pulseaudio \
@@ -204,7 +204,7 @@ define Package/pulseaudio-daemon-avahi/install
                $(1)/usr/lib \
                $(1)/usr/lib/pulseaudio \
                $(1)/usr/lib/pulse-$(PKG_VERSION)/modules \
-               $(1)/etc/dbus-1/system.d 
+               $(1)/etc/dbus-1/system.d
 
        $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/pulseaudio \