[packages] Fix linking of libsdl_{mixer,sound}
[openwrt/svn-archive/archive.git] / sound / pulseaudio / Makefile
index b42de6ef0c89d3f1da3e2e69504a8c894842dce3..734ca2f3d133811454274ba67ebe2f1688d37e61 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -56,8 +55,8 @@ SUPP_LIBS:=-L$(STAGING_DIR)/usr/lib/libintl/lib -L$(STAGING_DIR)/usr/lib/libicon
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib $(SUPP_LIBS)" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS) $(SUPP_LIBS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                LIBLTDL="$(STAGING_DIR)/usr/lib/libltdl.la" \
                X_CFLAGS="" \