Merge pull request #4853 from StevenHessing/noddos
[feed/packages.git] / sound / sox / Makefile
index 8fa571325773145de12215ff0be3b175e584d747..934b55465976e52accdd9f872ced54015d3b3946 100644 (file)
@@ -1,7 +1,4 @@
 #
-# Copyright (C) 2008 David Cooper <dave@kupesoft.com>
-# Copyright (C) 2006-2014 OpenWrt.org
-#
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
@@ -9,16 +6,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sox
-PKG_VERSION:=14.4.1
+PKG_VERSION:=14.4.2
 PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/sox
-PKG_MD5SUM:=ff9ca6aca972549de0e80e8e30ed379c
+PKG_HASH:=81a6956d4330e75b5827316e44ae381e6f1e8928003c6aa45896da9041ea149c
 
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
 PKG_LICENSE:=LGPL-2.1 GPL-2.0
 PKG_LICENSE_FILES:=COPYING LICENSE.LGPL LICENSE.GPL
 
+
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -29,12 +28,10 @@ TARGET_LDFLAGS+= \
 define Package/sox
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+BUILD_PATENTED:lame-lib +BUILD_PATENTED:libmad +BUILD_PATENTED:libid3tag \
-               +libvorbis +libvorbisidec +alsa-lib +libsndfile +libflac \
-               +libmagic +libpng +libffmpeg
+  DEPENDS:=+lame-lib +libmad +libid3tag +libmagic \
+               +libvorbis +alsa-lib +libflac
   TITLE:=Sox is a general purpose sound converter/player/recorder
   URL:=http://sox.sourceforge.net/
-  MAINTAINER:=Hamish Guthrie <hcg@openwrt.org>
 endef
 
 define Package/sox/description
@@ -45,24 +42,18 @@ define Package/sox/description
        several unix-style platforms.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
+CONFIGURE_ARGS += \
                --without-oss \
                --without-ao \
                --with-alsa \
                --without-libltdl \
-               --with-ogg \
                --with-flac \
-               --with-ffmpeg \
-               --without-amr-wb \
-               --without-amr-nb \
-               --without-samplerate \
                --without-ladspa \
-               --$(if $(CONFIG_BUILD_PATENTED),with-mad,without-mad) \
-               --$(if $(CONFIG_BUILD_PATENTED),with-lame,without-lame) \
-               --$(if $(CONFIG_BUILD_PATENTED),with-id3tag,without-id3tag) \
-       )
-endef
+               --without-png \
+               --without-sndfile \
+               --with-lame \
+               --with-id3tag \
+               --disable-openmp
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include