ramips: sercomm-payload: use pide-file argument
[openwrt/staging/dedeckeh.git] / target / linux / Makefile
index 828825011128de30973a466e5a46f52833a58be2..8eea40ee18a6dd032d9b858ec0e0f301675efa53 100644 (file)
@@ -1,12 +1,11 @@
-# 
-# Copyright (C) 2006-2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
+# SPDX-License-Identifier: GPL-2.0-only
 #
+# Copyright (C) 2006-2007 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
-prereq clean download prepare compile install menuconfig oldconfig update refresh: FORCE
-       TARGET_BUILD=1 $(MAKE) -C $(BOARD) $@
+export TARGET_BUILD=1
 
+prereq clean download prepare compile install oldconfig menuconfig nconfig xconfig update refresh: FORCE
+       @+$(NO_TRACE_MAKE) -C $(firstword $(wildcard feeds/$(BOARD) $(BOARD))) $@