[adm5120] switch to 2.6.24
[openwrt/svn-archive/archive.git] / target / linux / adm5120 / Makefile
index f8436c04ed2e363fe1761903b40876fe1ec327c0..c7c66705a3d6dc8858729d653c2080e79d2283eb 100644 (file)
@@ -1,27 +1,20 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007,2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 
-ARCH:=mipsel
 BOARD:=adm5120
-BOARDNAME:=ADM5120 (Little Endian)
-FEATURES:=squashfs jffs2 tgz broken
-
-LINUX_VERSION:=2.6.22.4
+BOARDNAME:=Infineon ADM5120
+LINUX_VERSION:=2.6.24
+SUBTARGETS:=router_le router_be
+INITRAMFS_EXTRA_FILES:=
 
-define Target/Description
-       Build firmware images for Infineon/ADMtek ADM5120 based boards
-       (e.g : RouterBoard RB1xx, Compex WP54G-WRT ...)
-endef
+include $(INCLUDE_DIR)/target.mk
 
-include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += admswconfig
 
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))