restore old patches for 2.6.21.5 kernel
[openwrt/staging/dedeckeh.git] / target / linux / adm5120-2.6 / patches / 001-adm5120.patch
index 8cc60678e02f8fcb846c68d08ce38ada52a67ef5..70129373f8382ec52e81095e8fb27f758c5df687 100644 (file)
@@ -1,11 +1,10 @@
-Index: linux-2.6.21.1/arch/mips/Kconfig
-===================================================================
---- linux-2.6.21.1.orig/arch/mips/Kconfig
-+++ linux-2.6.21.1/arch/mips/Kconfig
-@@ -16,6 +16,21 @@ choice
+diff -urN linux-2.6.19.2/arch/mips/Kconfig linux-2.6.19.2.new/arch/mips/Kconfig
+--- linux-2.6.19.2/arch/mips/Kconfig   2007-01-10 20:10:37.000000000 +0100
++++ linux-2.6.19.2.new/arch/mips/Kconfig       2007-01-23 14:49:38.000000000 +0100
+@@ -12,6 +12,21 @@
        prompt "System type"
        default SGI_IP22
+
 +config MIPS_ADM5120
 +      bool "Support for ADM5120 SoC"
 +      select SYS_HAS_CPU_MIPS32_R1
@@ -24,13 +23,12 @@ Index: linux-2.6.21.1/arch/mips/Kconfig
  config MIPS_MTX1
        bool "4G Systems MTX-1 board"
        select DMA_NONCOHERENT
-Index: linux-2.6.21.1/arch/mips/Makefile
-===================================================================
---- linux-2.6.21.1.orig/arch/mips/Makefile
-+++ linux-2.6.21.1/arch/mips/Makefile
-@@ -165,6 +165,14 @@ cflags-$(CONFIG_MACH_JAZZ)        += -Iinclude/
+diff -urN linux-2.6.19.2/arch/mips/Makefile linux-2.6.19.2.new/arch/mips/Makefile
+--- linux-2.6.19.2/arch/mips/Makefile  2007-01-23 14:02:57.000000000 +0100
++++ linux-2.6.19.2.new/arch/mips/Makefile      2007-01-23 14:49:39.000000000 +0100
+@@ -165,6 +165,14 @@
  load-$(CONFIG_MACH_JAZZ)      += 0xffffffff80080000
+
  #
 +# ADMtek 5120
 +#
@@ -43,14 +41,13 @@ Index: linux-2.6.21.1/arch/mips/Makefile
  # Common Alchemy Au1x00 stuff
  #
  core-$(CONFIG_SOC_AU1X00)     += arch/mips/au1000/common/
-Index: linux-2.6.21.1/include/asm-mips/bootinfo.h
-===================================================================
---- linux-2.6.21.1.orig/include/asm-mips/bootinfo.h
-+++ linux-2.6.21.1/include/asm-mips/bootinfo.h
-@@ -213,6 +213,42 @@
+diff -urN linux-2.6.19.2/include/asm-mips/bootinfo.h linux-2.6.19.2.new/include/asm-mips/bootinfo.h
+--- linux-2.6.19.2/include/asm-mips/bootinfo.h 2007-01-10 20:10:37.000000000 +0100
++++ linux-2.6.19.2.new/include/asm-mips/bootinfo.h     2007-01-23 14:49:40.000000000 +0100
+@@ -212,6 +212,42 @@
  #define MACH_GROUP_NEC_EMMA2RH 25     /* NEC EMMA2RH (was 23)         */
  #define  MACH_NEC_MARKEINS    0       /* NEC EMMA2RH Mark-eins        */
+
 +/*
 + * Valid machtype for group ADMtek ADM5120
 + */
@@ -88,5 +85,5 @@ Index: linux-2.6.21.1/include/asm-mips/bootinfo.h
 +#define MACH_ADM5120_ES2108PWR        30      /* ZyXEL Ethernet Switch 2108-PWR */
 +
  #define CL_SIZE                       COMMAND_LINE_SIZE
+
  const char *get_system_type(void);