apm821xx: add support for kernel 5.15 for testing
[openwrt/staging/noltari.git] / target / linux / apm821xx / Makefile
index c7e27d3214c44ae3ee9ed2a60b5e13918c294a22..f36274bd988250b415288bc505714d4f1fe8d1db 100644 (file)
@@ -1,17 +1,16 @@
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# SPDX-License-Identifier: GPL-2.0-only
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=apm821xx
 BOARDNAME:=AppliedMicro APM821xx
 CPU_TYPE:=464fp
-FEATURES:=fpu dt gpio
+FEATURES:=fpu dt gpio ramdisk squashfs usb
 SUBTARGETS:=nand sata
 
-KERNEL_PATCHVER:=5.4
+KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.15
 
 define Target/Description
        Build images for AppliedMicro APM821xx based boards.