apm821xx: add support for kernel 5.15 for testing
[openwrt/staging/noltari.git] / target / linux / apm821xx / Makefile
index eb34a3b3dc4bf1333f622f18af5e4b41da4ea6d6..f36274bd988250b415288bc505714d4f1fe8d1db 100644 (file)
@@ -1,19 +1,20 @@
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# SPDX-License-Identifier: GPL-2.0-only
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=apm821xx
 BOARDNAME:=AppliedMicro APM821xx
 CPU_TYPE:=464fp
-FEATURES:=fpu dt gpio
-MAINTAINER:=Chris Blake <chrisrblake93@gmail.com>, \
-           Christian Lamparter <chunkeey@gmail.com>
-SUBTARGETS:=nand
+FEATURES:=fpu dt gpio ramdisk squashfs usb
+SUBTARGETS:=nand sata
+
+KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.15
 
-KERNEL_PATCHVER:=4.4
+define Target/Description
+       Build images for AppliedMicro APM821xx based boards.
+endef
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -22,8 +23,4 @@ KERNELNAME:=uImage
 DEFAULT_PACKAGES += \
        kmod-leds-gpio kmod-i2c-core kmod-gpio-button-hotplug
 
-define Target/Description
-       Build images for AppliedMicro APM821xx based boards.
-endef
-
 $(eval $(call BuildTarget))