kernel: update linux 3.3 to 3.3.5
[openwrt/staging/dedeckeh.git] / target / linux / ar7 / Makefile
index 627fe22ad53aba438d14e8f9b020604584657e4a..74fe9d1935653e0f85b481efd7ad792880f6f63f 100644 (file)
@@ -1,5 +1,5 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,15 +10,17 @@ ARCH:=mipsel
 BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.27.22
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES+= kmod-pppoa ppp-mod-pppoa br2684ctl
+DEFAULT_PACKAGES+= kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl \
+               kmod-acx-mac80211 swconfig hostapd
 
 define Target/Description
-       Build firmware images for TI AR7 based routers
+       Build firmware images for TI AR7 based routers.
 endef
 
 $(eval $(call BuildTarget))