ar7: remove leftover 3.10 patches
[openwrt/staging/yousong.git] / target / linux / ar7 / Makefile
index b01c6c9a848ee521f48bfe426b2dfe73054bc7dd..c83a0923c3990ae9929a197d45ca8295db3c92b0 100644 (file)
@@ -1,5 +1,5 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=ar7
 BOARDNAME:=TI AR7
-FEATURES:=squashfs jffs2 atm
+FEATURES:=squashfs atm low_mem
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+SUBTARGETS:=generic ac49x
 
-LINUX_VERSION:=2.6.26.8
+KERNEL_PATCHVER:=3.14
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES+= kmod-pppoa ppp-mod-pppoa br2684ctl
+DEFAULT_PACKAGES+= swconfig
 
 define Target/Description
-       Build firmware images for TI AR7 based routers
+       Build firmware images for TI AR7 based routers.
 endef
 
 $(eval $(call BuildTarget))