[ar7] refresh kernel patches
[openwrt/svn-archive/archive.git] / target / linux / ar7 / patches-2.6.25 / 110-flash.patch
index 02f8d952f07a2e64f690d4325f357ad78fbe5476..350fe167f5d0d052cf0d41aa010228f3e30b029e 100644 (file)
@@ -1,8 +1,8 @@
-Index: linux-2.6.25.1/drivers/mtd/Kconfig
+Index: linux-2.6.25.4/drivers/mtd/Kconfig
 ===================================================================
---- linux-2.6.25.1.orig/drivers/mtd/Kconfig    2008-05-01 23:45:25.000000000 +0200
-+++ linux-2.6.25.1/drivers/mtd/Kconfig 2008-05-03 16:18:06.000000000 +0200
-@@ -158,6 +158,12 @@
+--- linux-2.6.25.4.orig/drivers/mtd/Kconfig
++++ linux-2.6.25.4/drivers/mtd/Kconfig
+@@ -168,6 +168,12 @@ config MTD_OF_PARTS
          the partition map from the children of the flash node,
          as described in Documentation/powerpc/booting-without-of.txt.
  
@@ -15,11 +15,11 @@ Index: linux-2.6.25.1/drivers/mtd/Kconfig
  comment "User Modules And Translation Layers"
  
  config MTD_CHAR
-Index: linux-2.6.25.1/drivers/mtd/Makefile
+Index: linux-2.6.25.4/drivers/mtd/Makefile
 ===================================================================
---- linux-2.6.25.1.orig/drivers/mtd/Makefile   2008-05-01 23:45:25.000000000 +0200
-+++ linux-2.6.25.1/drivers/mtd/Makefile        2008-05-03 16:18:06.000000000 +0200
-@@ -12,6 +12,7 @@
+--- linux-2.6.25.4.orig/drivers/mtd/Makefile
++++ linux-2.6.25.4/drivers/mtd/Makefile
+@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
  obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
  obj-$(CONFIG_MTD_AFS_PARTS)   += afs.o
  obj-$(CONFIG_MTD_OF_PARTS)      += ofpart.o
@@ -27,11 +27,11 @@ Index: linux-2.6.25.1/drivers/mtd/Makefile
  
  # 'Users' - code which presents functionality to userspace.
  obj-$(CONFIG_MTD_CHAR)                += mtdchar.o
-Index: linux-2.6.25.1/drivers/mtd/maps/physmap.c
+Index: linux-2.6.25.4/drivers/mtd/maps/physmap.c
 ===================================================================
---- linux-2.6.25.1.orig/drivers/mtd/maps/physmap.c     2008-05-01 23:45:25.000000000 +0200
-+++ linux-2.6.25.1/drivers/mtd/maps/physmap.c  2008-05-03 16:18:06.000000000 +0200
-@@ -87,7 +87,8 @@
+--- linux-2.6.25.4.orig/drivers/mtd/maps/physmap.c
++++ linux-2.6.25.4/drivers/mtd/maps/physmap.c
+@@ -87,7 +87,8 @@ static int physmap_flash_remove(struct p
  
  static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
  #ifdef CONFIG_MTD_PARTITIONS