ar71xx: add profile and build image for TP-LINK TL-WA801N/ND
[openwrt/staging/yousong.git] / target / linux / ar71xx / generic / profiles / buffalo.mk
index b459f32234ad5d8684a77e4320080cdff6a7a913..887be265710a6ff140314690067c89d46fd8b86f 100644 (file)
@@ -16,6 +16,17 @@ endef
 
 $(eval $(call Profile,WZRHPG300NH))
 
+define Profile/WZRHPG300NH2
+       NAME:=Buffalo WZR-HP-G300NH2
+       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WZRHPG300NH/Description
+       Package set optimized for the Buffalo WZR-HP-G300NH2
+endef
+
+$(eval $(call Profile,WZRHPG300NH2))
+
 define Profile/WZRHPAG300H
        NAME:=Buffalo WZR-HP-AG300H
        PACKAGES:=kmod-usb-ohci kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
@@ -26,3 +37,60 @@ define Profile/WZRHPAG300H/Description
 endef
 
 $(eval $(call Profile,WZRHPAG300H))
+
+define Profile/WZRHPG450H
+       NAME:=Buffalo WZR-HP-G450H
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WZRHPG450H/Description
+       Package set optimized for the Buffalo WZR-HP-G450H
+endef
+
+$(eval $(call Profile,WZRHPG450H))
+
+define Profile/WHRG301N
+       NAME:=Buffalo WHR-G301N
+       PACKAGES:=
+endef
+
+define Profile/WHRG301N/Description
+       Package set optimized for the Buffalo WHR-G301N.
+endef
+
+$(eval $(call Profile,WHRG301N))
+
+
+define Profile/WHRHPG300N
+       NAME:=Buffalo WHR-HP-G300N
+       PACKAGES:=
+endef
+
+define Profile/WHRHPG300N/Description
+       Package set optimized for the Buffalo WHR-HP-G300N
+endef
+
+$(eval $(call Profile,WHRHPG300N))
+
+
+define Profile/WHRHPGN
+       NAME:=Buffalo WHR-HP-GN
+       PACKAGES:=
+endef
+
+define Profile/WHRHPGN/Description
+       Package set optimized for the Buffalo WHR-HP-GN.
+endef
+
+$(eval $(call Profile,WHRHPGN))
+
+define Profile/WLAEAG300N
+       NAME:=Buffalo WLAE-AG300N
+       PACKAGES:=kmod-ledtrig-netdev
+endef
+
+define Profile/WLAEAG300N/Description
+       Package set optimized for the Buffalo WLAE-AG300N
+endef
+
+$(eval $(call Profile,WLAEAG300N))