ar71xx: add profile and generate image for the JA76PF2 board
[openwrt/staging/yousong.git] / target / linux / ar71xx / generic / profiles / buffalo.mk
index 74530b5e75b06cbf8566bab4bc81713e0c40f08a..afa47fb46b33220e65f3bf3a07aa9a0e1808ee17 100644 (file)
@@ -16,6 +16,17 @@ endef
 
 $(eval $(call Profile,WZRHPG300NH))
 
+define Profile/WZRHPG300NH2
+       NAME:=Buffalo WZR-HP-G300NH2
+       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WZRHPG300NH/Description
+       Package set optimized for the Buffalo WZR-HP-G300NH2
+endef
+
+$(eval $(call Profile,WZRHPG300NH2))
+
 define Profile/WZRHPAG300H
        NAME:=Buffalo WZR-HP-AG300H
        PACKAGES:=kmod-usb-ohci kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
@@ -27,6 +38,17 @@ endef
 
 $(eval $(call Profile,WZRHPAG300H))
 
+define Profile/WZRHPG450H
+       NAME:=Buffalo WZR-HP-G450H
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WZRHPG450H/Description
+       Package set optimized for the Buffalo WZR-HP-G450H
+endef
+
+$(eval $(call Profile,WZRHPG450H))
+
 define Profile/WHRG301N
        NAME:=Buffalo WHR-G301N
        PACKAGES:=