kernel: fix missing break in ubi auto-mounting patch
[openwrt/staging/hauke.git] / target / linux / ar71xx / generic / profiles / netgear.mk
index e8a2a3fbe63f6222b0bfc546a696a977f1565b31..2bce72124445c39021ad39e82f044f2c23fff935 100644 (file)
@@ -30,6 +30,7 @@ $(eval $(call Profile,WNDR3700))
 
 define Profile/WNR2000V3
        NAME:=NETGEAR WNR2000V3
+       PACKAGES:= -kmod-usb-core -kmod-usb-ohci -kmod-usb2 -kmod-ledtrig-usbdev
 endef
 
 define Profile/WNR2000V3/Description
@@ -62,8 +63,20 @@ endef
 $(eval $(call Profile,WNR612V2))
 
 
+define Profile/WNR1000V2
+       NAME:=NETGEAR WNR1000V2
+endef
+
+define Profile/WNR1000V2/Description
+       Package set optimized for the NETGEAR WNR1000V2
+endef
+
+$(eval $(call Profile,WNR1000V2))
+
+
 define Profile/WNR2200
-       NAME:=NETGEAR WNR2200
+  NAME:=NETGEAR WNR2200
+  PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/WNR2200/Description
@@ -71,3 +84,13 @@ define Profile/WNR2200/Description
 endef
 
 $(eval $(call Profile,WNR2200))
+
+define Profile/WPN824N
+       NAME:=NETGEAR WPN824N
+endef
+
+define Profile/WPN824N/Description
+       Package set optimized for the NETGEAR WPN824N
+endef
+
+$(eval $(call Profile,WPN824N))