ar71xx: Add support for Ubiquiti UniFi AP AC PRO
[openwrt/staging/noltari.git] / target / linux / ar71xx / generic / profiles / ubnt.mk
index d8e24d0032d75231d27be8207fe55294fd108282..69b83985bd6623c0d6732399d3e2cc8c0af9f9f1 100644 (file)
@@ -38,6 +38,28 @@ endef
 
 $(eval $(call Profile,UBNTUNIFI))
 
+define Profile/UBNTUNIFIACLITE
+       NAME:=Ubiquiti UniFi AP AC LITE/LR
+       PACKAGES:=kmod-ath10k ath10k-firmware-qca988x
+endef
+
+define Profile/UBNTUNIFIACLITE/Description
+       Package set optimized for the Ubiquiti UniFi AP AC LITE/LR.
+endef
+
+$(eval $(call Profile,UBNTUNIFIACLITE))
+
+define Profile/UBNTUNIFIACPRO
+       NAME:=Ubiquiti UniFi AP AC PRO
+       PACKAGES:=kmod-ath10k ath10k-firmware-qca988x kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNTUNIFIACPRO/Description
+       Package set optimized for the Ubiquiti UniFi AP AC PRO.
+endef
+
+$(eval $(call Profile,UBNTUNIFIACPRO))
+
 define Profile/UBNTUNIFIOUTDOOR
        NAME:=Ubiquiti UniFiAP Outdoor
        PACKAGES:=