move inclusion of the mach-ar71xx/Kconfig into the right patch
[openwrt/staging/wigyori.git] / target / linux / ar71xx / patches-2.6.27 / 001-ar71xx_core.patch
index 8ff96e306a93a7e3aaf3172552cfb40d93e440b0..5db99d6a82c94845704bdc9ba720f4329eea42cb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -577,6 +577,13 @@
+@@ -577,6 +577,13 @@ core-$(CONFIG_TOSHIBA_RBTX4927)   += arch/
  #
  core-$(CONFIG_TOSHIBA_RBTX4938) += arch/mips/txx9/rbtx4938/
  
 +#define MACH_AR71XX_RB_411    2       /* MikroTik RouterBOARD 411/411A/411AH */
 +#define MACH_AR71XX_RB_433    3       /* MikroTik RouterBOARD 433/433AH */
 +#define MACH_AR71XX_RB_450    4       /* MikroTik RouterBOARD 450 */
-+#define MACH_AR71XX_RB_493    5       /* Mikrotik RouterBOARD 493/493AH */
++#define MACH_AR71XX_RB_493    5       /* MikroTik RouterBOARD 493 */
 +
  #define CL_SIZE                       COMMAND_LINE_SIZE
  
  extern char *system_type;
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -22,6 +22,23 @@
+@@ -22,6 +22,23 @@ choice
  config MACH_ALCHEMY
        bool "Alchemy processor based machines"
  
  config BASLER_EXCITE
        bool "Basler eXcite smart camera"
        select CEVT_R4K
+@@ -598,6 +615,7 @@ config WR_PPMC
+ endchoice
++source "arch/mips/ar71xx/Kconfig"
+ source "arch/mips/au1000/Kconfig"
+ source "arch/mips/basler/excite/Kconfig"
+ source "arch/mips/jazz/Kconfig"